1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Thread variable is NULL

Discussion in 'Styling and Customization Questions' started by Franklyn, Nov 5, 2014.

  1. Franklyn

    Franklyn New Member

    I try to dump the Thread variable in a part of my Template but I get everytime "NULL" ? I tried to Dump the Forum and Visitor variables and these works fine.

    Code:
    {xen:helper dump, $thread}
    What is the problem?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    The $thread param isn't available in that template.
     
  3. Franklyn

    Franklyn New Member

    Exist a Way to include it? I want to know only if Im in a Thread Page...
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    By "in a thread page", do you mean the thread_view template?

    If so, you may be able to use a template conditional statement, depending what it is you are trying to do.

    <xen:if is="{$contentTemplate} == 'xyz'">
     
  5. Franklyn

    Franklyn New Member

    In short, I don't want to show a specific content in Threads.

    Something like:

    <xen:if is="!{$is_thread}">
    custom content
    </xen:if>
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    It's still not clear what it is you are trying to do.

    Can you screenshot exactly what content you are trying to prevent being displayed on which page?
     
  7. Franklyn

    Franklyn New Member

    I added a Ad Code in my "ad_below_top_breadcrumb" template... It works fine in all pages (node/forums/thread) of my XF. But I want that this Code will not displayed in ALL Threads Pages of my XF.
     
  8. Brogan

    Brogan XenForo Moderator Staff Member

  9. Franklyn

    Franklyn New Member

    Thanks very much it works!
     

Share This Page