Resource icon

Thread Multi Moderation 1.2.0

No permission to download

MOZ

Well-known member
LOL, you didn't read my earlier post? I changed it even before this version :p
 

MagnusB

Well-known member
Can you add the option of starting a conversation with the OP when there thread is deleted or moved to a particular section.
I would also be very interested in this...

I also just updated to latest version and I keep getting this error when trying to do changes:
Server Error

Mysqli prepare error: Unknown column 'description' in 'field list'
  1. Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
  2. Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
  3. Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
  4. Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 574
  5. Zend_Db_Adapter_Abstract->insert() in XenForo/DataWriter.php at line 1591
  6. XenForo_DataWriter->_insert() in XenForo/DataWriter.php at line 1580
  7. XenForo_DataWriter->_save() in XenForo/DataWriter.php at line 1381
  8. XenForo_DataWriter->save() in Ragtek/MM/ControllerAdmin/Multimod.php at line 90
  9. Ragtek_MM_ControllerAdmin_Multimod->actionSave() in XenForo/FrontController.php at line 310
  10. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
  11. XenForo_FrontController->run() in ~/public_html/admin.php at line 13

I might have skipped one or two of the intermediate updates, I think I was on 1.1.0 PL1 before updating
 
R

ragtek

Guest
hm, this should have been added while the instalaltion / upgrade:(

PHP:
    public function _installVersion12(){
        self::addColumn(self::ADDON_PRIMARY_TABLE, 'description', " TEXT CHARACTER SET utf8 COLLATE utf8_general_ci");
    }

to fix it, you could run this query:

Code:
 alter table xf_r_multimod add description TEXT CHARACTER SET utf8 COLLATE utf8_general_ci
 

ashkir

Active member
Newest update has an error. :( We're trying to use it.

Undefined index: description
  1. XenForo_Application::handlePhpError() in Ragtek/MM/Model/Multimod.php at line 194
  2. Ragtek_MM_Model_Multimod->runMultiMod() in Ragtek/MM/Extend/ControllerPublic/Thread.php at line 79
  3. Ragtek_MM_Extend_ControllerPublic_Thread->actionRunMultiMod() in XenForo/FrontController.php at line 310
  4. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
  5. XenForo_FrontController->run() in /home/rpgdir/public_html/index.php at line 13
 

ashkir

Active member
Links are disappearing in the latest update (since it went to the ajax) and they don't load back after they been hovered over. :(

Otherwise, we're loving this and we're glad to have asked for it t obe developed.
 

Aceros

Active member
Links are disappearing in the latest update (since it went to the ajax) and they don't load back after they been hovered over. :(.

I'm having this issue as well.

To be more specific: When 2 options are available in the multi-mod, hovering over the first option truncates the list to 1 entry (removing the second). If you go off the multi-mod & back on so as to not mouse over the first entry and just hover over the second, it's accessible.

Any ideas on solution? Otherwise one of the most awesome mods for Xenforo, I really needed this feature after converting from IPB!
 

ashkir

Active member
Still getting this error. :( And it's really annoying our staff. We're kind of wanting to revert to an older version now. But, we're afraid if we do we might lose the settings.

Anyone know how to turn off the ajax feature? It started with ajax fetch update.
 
R

ragtek

Guest
If anybody else is having this problem, change your template ragtek_mm_list to
Code:
<xen:title>{xen:phrase ragtek_multimods}</xen:title>
 
<xen:navigation>
<xen:breadcrumb source="$nodeBreadCrumbs" />
<xen:breadcrumb href="{xen:link full:threads, $thread}">{xen:helper threadPrefix, $thread}{$thread.title}</xen:breadcrumb>
</xen:navigation>
 
<xen:container var="$bodyClasses">{xen:helper nodeClasses, $nodeBreadCrumbs, $forum}</xen:container>
<xen:container var="$searchBar.thread"><xen:include template="search_bar_thread_only" /></xen:container>
<xen:container var="$searchBar.forum"><xen:include template="search_bar_forum_only" /></xen:container>
 
 
 
        <ul class="secondaryContent blockLinksList">
            <xen:if is="{$multimods}">
            <xen:foreach loop="$multimods" value="$mod">
                <li class="listItem PopupItemLink">
                  <a href="{xen:link 'threads/run-multi-mod', $thread, 'mod_id={$mod.multimod_id}'}" class="OverlayTrigger Tooltip"
title="<xen:if is="{$mod.description}">{$mod.description}<xen:else />{$mod.title}</xen:if>
">{$mod.title}</a>
                </li>
            </xen:foreach>
                <xen:else />
                {xen:phrase ragtek_mm_nothing_available}
            </xen:if>
        </ul>

The "removing" of the elemenents in the list happened only for entries without an description, that's why i was never able to reproduce it on my test board:(
I don't know why it happened and if there's a nicer fix, but the above posted code inserts the title if no description is set for the multi mod action.
 

swatme

Well-known member
If anybody else is having this problem, change your template ragtek_mm_list to

.


hi ragtek is it possible to have a permission setting
CAN USE MULTI MODERATION BY SELF THREAD
that way certain groups can use multi-moderate in their own thread started by them only

or

Theres an checkbox in the Multi moderation settings
[] Enable only this multimod if thread starter

That way a specific multimod setup can only be shown if they own the thread

thanks
 

Luis

Well-known member
Download as ZIP the addon from Github --> https://github.com/ragtek/MM/archive/master.zip
Extract the ZIP file on your PC, you will get a folder called --> MM-master.
Rename the folder MM-master to MM
In your forum inside the library folder create a folder called Ragtek.
Upload the folder MM from your PC into the folder Ragtek created earlier.
Install the addon from your admin panel:
  • To install from your PC look inside the MM folder the folder called Dev,inside the folder Dev look for the installation file called Thread Multi Moderation_1.2.0_b_15_en-US.xml.
  • To install from the server, try the next route --> ./library/Ragtek/MM/Dev/Multi Moderation_1.2.0_b_15_en-US.xml
 

Robyn Unc Privette

Active member
Are you familiar with this add on or you just know how to install? I'm having an error when I try to add a multi moderation entry.

Mysqli prepare error: Unknown column 'reply_creator_user_id' in 'field list'
  1. Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
  2. Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
  3. Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
  4. Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 574
  5. Zend_Db_Adapter_Abstract->insert() in XenForo/DataWriter.php at line 1591
  6. XenForo_DataWriter->_insert() in XenForo/DataWriter.php at line 1580
  7. XenForo_DataWriter->_save() in XenForo/DataWriter.php at line 1381
  8. XenForo_DataWriter->save() in Ragtek/MM/ControllerAdmin/Multimod.php at line 83
  9. Ragtek_MM_ControllerAdmin_Multimod->actionSave() in XenForo/FrontController.php at line 310
  10. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
  11. XenForo_FrontController->run() in /home/robynswo/public_html/forum/admin.php at line 13
 

Eoj Nawoh

Active member
Hello,


#0 /home/--/public_html/library/Ragtek/MM/Extend/ControllerPublic/Thread.php(30): XenForo_Application::handlePhpError(8, 'Undefined index...', '/home/thesecr1/...', 30, Array)
#1 /home/--/public_html/library/XenForo/FrontController.php(310): Ragtek_MM_Extend_ControllerPublic_Thread->actionIndex()
#2 /home/--/public_html/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#3 /home/--/public_html/index.php(13): XenForo_FrontController->run()
#4 {main}


We keep getting this error from the addon.
 
Top