[TH] Question and Answer Forums

[TH] Question and Answer Forums [Paid] 1.1.4 Patch Level 2

No permission to buy ($35.00)

AndrewSimm

Active member
It would be great if you had a separate mod for up and down vote. I use this on my vbulletin site opposed to other rating options.
 

invictus

Active member
I purchased this and I'm happy with it so far.

One critique I have is that the best answer is not visually distinguishable enough from other posts. The only difference is the color of the trophy icon.

If possible, could you please add a class to <div class="message-inner"> for the post that is marked best answer? For example you could change it to <div class="message-inner thqa-best-answer"> or similar, this way we can apply some CSS to it to suit our taste.

Thanks!
 

invictus

Active member
Also, can we get a question mark icon in threadlist for unanswered threads, similar to how you have a check mark icon for answered threads?

This will be helpful for forums that have mixed content, question threads and normal threads.

Thanks!
 

Jake B.

Well-known member
It would be great if you had a separate mod for up and down vote. I use this on my vbulletin site opposed to other rating options.
For something like that to be used within normal discussions it'd be nearly required to be able to have threaded replies. The lack of threaded replies is pretty much the only reason we included the button to sort by date, and don't have an option to disable that

I purchased this and I'm happy with it so far.

One critique I have is that the best answer is not visually distinguishable enough from other posts. The only difference is the color of the trophy icon.

If possible, could you please add a class to <div class="message-inner"> for the post that is marked best answer? For example you could change it to <div class="message-inner thqa-best-answer"> or similar, this way we can apply some CSS to it to suit our taste.

Thanks!
Yeah, makes sense. Can add that in to the next release!
https://github.com/Audentio/xf2addon-issues/issues/34

Also, can we get a question mark icon in threadlist for unanswered threads, similar to how you have a check mark icon for answered threads?

This will be helpful for forums that have mixed content, question threads and normal threads.

Thanks!
Same as above :)
https://github.com/Audentio/xf2addon-issues/issues/35
 

KawaiiHannah

Active member
I'm having issues with this add on I get
Code:
INSERT  INTO xf_thread (`node_id`, `user_id`, `username`, `discussion_state`, `title`, `discussion_open`, `sticky`, `th_is_qa_qaforum`, `post_date`, `last_post_date`, `last_post_user_id`, `last_post_username`, `thread_id`, `reply_count`, `view_count`, `discussion_type`, `first_post_id`, `last_post_id`, `first_post_likes`, `prefix_id`, `custom_fields`, `tags`, `th_answered_qaforum`) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)
------------

#0 src/XF/Db/Mysqli/Statement.php(174): XF\Db\AbstractStatement->getException('MySQL query err...', 1364, 'HY000')
#1 src/XF/Db/Mysqli/Statement.php(70): XF\Db\Mysqli\Statement->getException('MySQL query err...', 1364, 'HY000')
#2 src/XF/Db/AbstractAdapter.php(69): XF\Db\Mysqli\Statement->execute()
#3 src/XF/Db/AbstractAdapter.php(146): XF\Db\AbstractAdapter->query('INSERT  INTO xf...', Array)
#4 src/XF/Mvc/Entity/Entity.php(1343): XF\Db\AbstractAdapter->insert('xf_thread', Array)
#5 src/XF/Mvc/Entity/Entity.php(1085): XF\Mvc\Entity\Entity->_saveToSource()
#6 src/XF/Service/Thread/Creator.php(285): XF\Mvc\Entity\Entity->save(true, false)
#7 src/XF/Service/ValidateAndSavableTrait.php(40): XF\Service\Thread\Creator->_save()
#8 src/XF/Pub/Controller/Forum.php(714): XF\Service\Thread\Creator->save()
#9 src/XF/Mvc/Dispatcher.php(249): XF\Pub\Controller\Forum->actionPostThread(Object(XF\Mvc\ParameterBag))
#10 src/XF/Mvc/Dispatcher.php(89): XF\Mvc\Dispatcher->dispatchClass('XF:Forum', 'post-thread', 'json', Object(XF\Mvc\ParameterBag), 'forums', Object(ThemeHouse\QAForums\XF\Pub\Controller\Forum), NULL)
#11 src/XF/Mvc/Dispatcher.php(41): XF\Mvc\Dispatcher->dispatchLoop(Object(XF\Mvc\RouteMatch))
#12 src/XF/App.php(1844): XF\Mvc\Dispatcher->run()
#13 src/XF.php(328): XF\App->run()
#14 index.php(13): XF::runApp('XF\\Pub\\App')
#15 {main}
 

Jake B.

Well-known member
Yeah, I just saw and replied to your ticket

Looks like you have this installed and it is causing the issue. It's possible that if you did uninstall it the developer doesn't properly remove the fields so I'd recommend contacting them about the issue :)
 

Dnyan Deshmukh

Well-known member
I think dev has fixed this issue i reported something similar error when i uninstall that add on.

Can i see a live demo of your addon
 

Jake B.

Well-known member
I think dev has fixed this issue i reported something similar error when i uninstall that add on.

Can i see a live demo of your addon
We don't currently have a public demo available for our add-ons, shoot me a PM and we can set something up for you :)
 

Jake B.

Well-known member
Looks like it was caused because you didn't have any forums setup as Q&A Forums, which I didn't plan for in the upgrade. Just redownload the files and run the upgrade again with the updated files :)
 

ThemeHouse

Well-known member

Kintaro

Well-known member
How about a random sorting view so it can be used for competitions, votes, referrals posting, etc... in this way every post can have the same exposure.
 

Jake B.

Well-known member
Random sorting could cause all sorts of issues, a big one would be pagination, a lot of posts would get completely missed and you’d see some others multiple times
 

Ranger375

Well-known member
Is there a way to remove the "sort by votes" button? Also, the "sort by votes" button appears on every forum, regardless of whether you designated that forum to use the addon or not.
 

Jake B.

Well-known member
The sort by votes button isn't supposed to display on non Q&A threads so i'll look into why that's happening. Currently no way to disable that button on Q&A threads as that view adds most of the functionality
 

Ranger375

Well-known member
When I use my iPhone to respond in the Q&A threads I can’t see the text when I am typing a response. The keyboard covers it up. When I disable the addon it’s not an issue.
 
Top