1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Template Editing

Discussion in 'Styling and Customization Questions' started by Amaury, Dec 20, 2013.

  1. Amaury

    Amaury Well-Known Member

    Why is it that if a make a template edit somewhere to change, say, text color from red to blue, a yellow border I have on the sub-heading, which is set via the Sub-Heading style property, changes to transparent?

    In order to fix it, I have to revert the style property and re-apply my changes.
  2. Jeremy

    Jeremy XenForo Moderator Staff Member

    If you edit a style property via the templates you actually edit the style property.
  3. Amaury

    Amaury Well-Known Member

    I don't think I'm editing a style property in the template, though. Here's a video (watch in full screen and 1080p):

  4. Russ

    Russ Well-Known Member

    Possibly due to declaring only a color for ALL, and no style/width for ALL. Editing the CSS is probably correcting it automatically. Try putting in a value for the ALL width/style and doing the same steps.
    Amaury likes this.
  5. Amaury

    Amaury Well-Known Member

    I don't think that's the problem, because it messes with the Item Page Nav Link, Hover State style property as well. However, by XenForo default, the border is "All" without any style and width.
  6. Russ

    Russ Well-Known Member

    Actually... default:

  7. Amaury

    Amaury Well-Known Member

    Read my post again. That's the default for Sub-Heading, but check Item Page Nav Link, Hover State.
  8. Russ

    Russ Well-Known Member

    Well I just tried on the default style and it works accordingly, I'd suggest(back up your style first) revert the subheading property, then go and try to edit the same value you did in the video, see if you can replicate it.
  9. Amaury

    Amaury Well-Known Member

    @Russ, you were right. It had to do with the blank Style and Width fields. When I made my Christmas Day style yesterday, I set the top and bottom borders for Sub-Heading to transparent and removed their style and width and then put a color in the all border box and gave it a style and width; when I made the template edits, the Sub-Heading style property was unaffected.

    In which case, I'm not sure why the hover border for the pagination on the discussion list doesn't have style and width by default.

Share This Page