1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TAC(Tenants Anti-Spam Collection) - Anti-Spam Complete Collection [Paid] [Deleted]

Discussion in 'Add-on Releases' started by tenants, Mar 4, 2013.

  1. tenants

    tenants Well-Known Member

    tenants submitted a new resource:

    TAC(Tenants Anti-Spam Collection) - Anti-Spam Complete Collection (version 1.0.0) - Anti Bot, Anti Country, Anti human, Api, Captcha ... Anit SPAM Collection!

    Read more about this resource...
     
  2. CyclingTribe

    CyclingTribe Well-Known Member

    Nice one - a great value bundle - thanks. (y)
     
  3. Mouth

    Mouth Well-Known Member

    Awesome :) Without sounding like a penny pinching scrooge, is their any discount if you have already purchased one of the add-0n's in the pack? :love:
     
  4. tenants

    tenants Well-Known Member

    For those that already own FoolBotHoneyPot (before Today, 04/03/2013)... I'm going to throw this collection over to you for free.
    But.. on the condition that you don't complain when I give another collection out that's exactly the same as this, but it will containing branding (and it will be free for everyone)

    The FoolBotHoneyPot users have really made it possible to make this Add-on collection (The other plugins didn't make nearly as much), so it's free to upgrade for users of FBHP (as a thank you)

    It's a very complete anti spam collection, I'll still be improving the StopHumanSpam part, but apart from that, everything thing else has had quite a few versions.. and as you know FBHP stops 100% of bots, any API allows you to add just about any API, you can block known "spam countries" .. kill spam with your own Custom Image Captcha, and well... the rest of the descriptions are in the links ;) There's a lot to it

    I'll add all FoolBotHoneyPot users to the paid version (unbranded version) now.

    The add-ons are now located in a sub folder "library/Tac"

    I haven't found a problem upgrading, but it might be safer to un-install your previous versions (if you have a previous version of anything above)
     
    CyclingTribe, Mouth and Deebs like this.
  5. Mouth

    Mouth Well-Known Member

    Wow! That's a terrific surprise, thanks! :D
     
    CyclingTribe likes this.
  6. tenants

    tenants Well-Known Member

    I've just installed the pack, and found one bug with FaceBookRegCaptcha

    Just replace the file located here:
    library\Tac\FaceBookRegCaptcha\ControllerPublic\Register.php

    With the attached (It will be fixed in the next version, but I would rather concentrate on making updates for StopHumanSpam for now):
     

    Attached Files:

    Mouth likes this.
  7. CyclingTribe

    CyclingTribe Well-Known Member

    Yup, excellent stuff - thanks tenants, much appreciated! (y)
     
  8. tenants

    tenants Well-Known Member

  9. tenants

    tenants Well-Known Member

  10. Mouth

    Mouth Well-Known Member

  11. tenants

    tenants Well-Known Member

    Who would have thought moving a few files into a folder could cause so many issues, I'll update it now
     
  12. tenants

    tenants Well-Known Member

    oh, wait... if you are using this with FBHP, turn off stopProxies (it's not needed, and you'll get more information from FoolBotHoneyPot about the bots)
     
  13. Mouth

    Mouth Well-Known Member

    OK.

    Hahahahaha ...

    I untick "Enable StopProxies", then click 'Save Changes' and the browser immediately loads http://xenforo.com/community/threads/stopcountryspam-paid.36271/#post-412948 as a result of clicking the Save Changes button. Reload /admin.php?options/list/StopCountrySpam and 'Enable StopProxies' is still selected/ticked. Thus, I cannot turn it off :eek:
     
  14. tenants

    tenants Well-Known Member

    How bizarre, well I've just made a fix... can you give it a whirl and let me know if you see the same issue

    Tac Anti Spam - Paid (Brand Free)_v1_0_0e.zip
     
  15. tenants

    tenants Well-Known Member

    Okay, I thought I tested this.. but I realise why you saw the errors but I didn't.

    I use StopBotResource, so the bots that usually get logged with stopProxies don't even make it to the registration page.. hence, I would never have seen the bug.

    The redirection, that's just plain weird, let me know if it happens again with the latest version
     
  16. Mouth

    Mouth Well-Known Member

    No, no more of that issue in the log. But I also turned-off the StopProxies, so perhaps that has corrected it anyways.

    Looks to have been a local browser issue, sorry. Swapped from Safari to Chrome and it worked properly.
     
  17. Ernest L. Defoe

    Ernest L. Defoe Well-Known Member

    I had someone try to register and they got this when trying to register. What do I need to do to fix it.

    Please enter a value for the required field 'request_response'.
    Please enter a value for the required field 'country_detected'.
     
  18. tenants

    tenants Well-Known Member

    oh, you need to set up StopCountrySpam if you've installed it.

    There are two fields in the StopCountrySpam options, under the fields it mentions you need to set these by following the instructions here:
    http://xenforo.com/community/threads/stopcountryspam-paid.36271/#post-412948

    I did have these filled by default, but I don't think it is right to do so.

    To set these, you can use any of the following settings


    literally copy and paste the values into the two fields,
    Obviously, when it say "none" above, leave the field blank

    example:

    pastein.png



    I personally use wipmania, since they offer infinite requests, regular updates and its free, see here: http://www.wipmania.com/en/api/#apitab_wie_a
    They also have paid versions which is more reliable, the free version only returns the country code (but that's all StopCountrySpam requires)
     
  19. Ernest L. Defoe

    Ernest L. Defoe Well-Known Member

    Okay I have everything setup just like in the pic and I am still getting this error when I try to register a "dummy" account.

    Please enter a value for the required field 'country_detected'.
     
  20. Ernest L. Defoe

    Ernest L. Defoe Well-Known Member

    Got the one issue fixed now when trying to register a "dummy" account it gives the error about not accepting new registrations. What am I doing wrong?
     

Share This Page