1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

symlink - no such file or directory

Discussion in 'Server Configuration and Hosting' started by Adam Howard, Feb 14, 2013.

  1. Adam Howard

    Adam Howard Well-Known Member

    I've tried

    ln -s /sociallyuncensored.eu/public_html/forums/data /sociallyuncensored.com/public_html/data

    and also I tried

    ln -sf /sociallyuncensored.eu/public_html/forums/data /sociallyuncensored.com/public_html/data

    Always ends the resolve with

    ln: creating symbolic link `/sociallyuncensored.com/public_html/data': No such file or directory

    Now I've made the folder manually in both places, without in both places, and even tried swapping from one place to another. Same outcome.

    I'm using this as the user account and not root, because I need /data/ to be chmod 777 for that users.
     
  2. Adam Howard

    Adam Howard Well-Known Member

    OK doing the full path

    /home/USER/domains/sociallyuncensored.eu/public_html/forums/data /home/USER/domains/sociallyuncensored.com/public_html/data

    May have worked.... But I'm not sure because FTP does not seem to want to follow the symlink
     
  3. Luke F

    Luke F Well-Known Member

    If you're using pure-ftpd you need a special compile flag to enable symlink support (why oh why don't they make this a config file option), and you have to be extra careful not to introduce security holes with it
     
  4. Adam Howard

    Adam Howard Well-Known Member

    I guess I'm not really worried about FTP following it, per say. That's just normally how I would have tested it before pointing the site in X direction.

    As long as it write to it sociallyuncensored.eu/forums/data/ and http accepts sociallyuncensored.com/data/ for a true static and cookie less domain... I'll be good.
     

Share This Page