1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Switched to Ubuntu - Avatar Error

Discussion in 'Troubleshooting and Problems' started by Kevin J Cohen, May 10, 2012.

  1. Kevin J Cohen

    Kevin J Cohen Member

    I get this error whenever I try to upload an avatar:

    "The image could not be processed by the server. Please try another or contact the site owne"

    I just recently switched to a linode running ubuntu. Any ideas on how to fix?
  2. Jesepi

    Jesepi Well-Known Member

    Make sure the php gd library is installed.
  3. Kevin J Cohen

    Kevin J Cohen Member

    How can I verify?
  4. Kevin J Cohen

    Kevin J Cohen Member

    I tried this:

    However Ubuntu (and Debian) comes with package called php5-gd
    Just type following command to install this module:
    # apt-get install php5-gd

    Still doesn't work.
  5. Adam Howard

    Adam Howard Well-Known Member

    Ah, Ubuntu / Debian ..... This I can help you with.....

    apt-get install aptitude

    aptitude is like an advance version of apt-get. It will in advance inform you of needed resources, packages, and possible conflicts.

    aptitude update
    aptitude full-upgrade (will upgrade you to Ubuntu 12.04 current)

    If no errors and it did update, reboot (type reboot).

    After do this....

    aptitude install php5-curl php5-gd php5-intl php-pear php5-imagick

    (This should cover every imagine format you come over)

    /etc/init.d/apache2 restart
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Visit admin.php?tools/phpinfo

    You should see the gd library:

    Screen shot 2012-05-09 at 8.45.37 PM.png

    Assuming you are using gd and not imagemagick:

    Admin CP -> Home -> Options -> Attachments -> Default Image Processor
  7. Kevin J Cohen

    Kevin J Cohen Member

    It was a permissions issue :)

    Just had to set data and data_internal to chmod 775
    Jake Bunce and TheVisitors like this.

Share This Page