1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Switched path to data dir, but XMG sitemap URL's remain old

Discussion in 'Media Gallery Resolved Bugs' started by kontrabass, Mar 1, 2016.

Tags:
  1. kontrabass

    kontrabass Well-Known Member

    I switched the path to my XF data directory (swapped CDN domain names). On the site itself the media gallery thumbnails etc are all fine, using the new URL. But my xml sitemap, despite the change happening over a year ago, still has old media gallery URL's in it using the old cdn domain. So Google is giving me 24k errors in my sitemap which I find annoying ;) .

    I've rebuilt everything, but no matter what I do the sitemap still contains these out-dated URL's. Any tips on how to get the sitemap to start fresh?
     
  2. Chris D

    Chris D XenForo Developer Staff Member

    This isn't actually sitemap specific.

    The thumbnails are actually missing:
    http://www.talkbass.com/media/albums?page=28

    I recommend doing a full media thumbnail rebuild followed by doing a full album thumbnail rebuild. This should sort it out.
     
  3. kontrabass

    kontrabass Well-Known Member

    I remember trying this before, but I just got done doing a full album thumbnail rebuild, and then a full album rebuild per your suggestion. No change, it's still trying to load from the old static.talkbass..... url

    Can this maybe be from having [bd] attachment store installed a while back (since uninstalled)? Not sure... I'll investigate what I can.

    Screenshot at Mar 01 09-11-12.png
     
    Last edited: Mar 1, 2016
  4. Chris D

    Chris D XenForo Developer Staff Member

    Aha...

    This could happen if you have used the "Change Album Thumbnail" feature. It would cache the thumbnail URLs and the thumbnail rebuild deliberately skips them.

    Let's see how many you have and whether that album is one of them...

    Code:
    SELECT album_id, album_title
    FROM xengallery_album
    WHERE manual_media_cache = 1
        OR album_thumbnail_date > 0
    There wouldn't really be an ideal way of being able to automatically clean this up aside from going to each affected album and clicking "Change Album Thumbnail" and selecting "Random". This would ultimately rebuild the thumbnail and recache the thumbnail URLs.

    If there is a lot of them, we can probably work out an easier way to do this.

    I'm actually going to move this to bugs for now as I think we probably need a better solution eventually. We cache the full thumbnail URL to save processing it, but clearly that causes problems in cases like this.
     
  5. kontrabass

    kontrabass Well-Known Member

    Looks like there are 47 of them. I guess it's do-able one at a time :)

    Code:
    mysql> SELECT album_id, album_title
        -> FROM xengallery_album
        -> WHERE manual_media_cache = 1
        ->     OR album_thumbnail_date > 0;
    +----------+------------------------------------------+
    | album_id | album_title                              |
    +----------+------------------------------------------+
    |       17 | Rick Turner Renaissance RB5 fretless     |
    |       18 | Rick Turner Renaissance RB5 fretted      |
    |       19 | Warwick Alien 5                          |
    |       20 | Crook Custom 5 "Tele" Bass               |
    |       27 | FretNoMore                               |
    |       90 | The Bassic Life                          |
    |      109 | Alembic Basses                           |
    |      128 | Fender Jazz V                            |
    |      155 | Gear Pics                                |
    |      179 | Pedalboard                               |
    |      183 | 1996 Jazz V                              |
    |      185 | Ibanez SR400 (2002)                      |
    |      259 | Cab Builds                               |
    |      335 | Parts is parts                           |
    |      358 | Mosfed's boards and effects              |
    |      359 | Breeder Feedback Fridays                 |
    |      369 | Modulus Q5                               |
    |      370 | Yamaha BB3000AF                          |
    |      371 | Sadowsky RV5 w/VTC                       |
    |      372 | Michael Kelly Dragonfly 5                |
    |      373 | '75 Fender Jazz Bass                     |
    |      374 | Warmoth Gecko 5                          |
    |      375 | Godin A5 SA                              |
    |      376 | Godin A5 Fretless                        |
    |      416 | G&L L2500 USA                            |
    |      417 | Fender Jazz Bass Special MIJ             |
    |      418 | Fender Jazz Bass DeLuxe MIJ              |
    |      419 | Westone Headless X900TPR                 |
    |      420 | All my babys                             |
    |      440 | Recording session                        |
    |      441 | Gigging photos                           |
    |      443 | Yammie RBX170                            |
    |      452 | Woodpile                                 |
    |      488 | Music Man Bongo 4HH                      |
    |      501 | Rhoney Oceana VI                         |
    |      532 | My Gear                                  |
    |      567 | Bassman                                  |
    |      568 | Strap                                    |
    |      631 | Bass Gear for sale                       |
    |      722 | Luciano Golia Doublebass " Firenze" 2015 |
    |      750 | The Shortie Family                       |
    |      764 | Hartke 3500                              |
    |      765 | Traynor YBA-200                          |
    |      766 | Aguilar GS-410                           |
    |      771 | Gear                                     |
    |      773 | Show Pictures                            |
    |      804 | Warwick Thumb LE                         |
    +----------+------------------------------------------+
    47 rows in set (0.01 sec)
    
     
  6. Chris D

    Chris D XenForo Developer Staff Member

    And are these the ones that have broken thumbs? If so, that explains everything :)
     
  7. kontrabass

    kontrabass Well-Known Member

    Yes those are the broken thumbs. I went through and regenerated random thumbnails for all of them. Hopefully the sitemap will have valid url's now too :)

    Thanks!
     
  8. Chris D

    Chris D XenForo Developer Staff Member

    Yes, it will do.

    Still need a longer term solution so we'll keep the bug report open until we have an update on that.
     
  9. Chris D

    Chris D XenForo Developer Staff Member

    Turns out as well as caching the thumbnail URL, we also cache all of the parts required to build a thumbnail URL so from here on, that's what we'll do. This should mean that changing things like the data path/URL will now return the correct thumbnail URL in all cases.

    Thanks :)
     
    kontrabass and eva2000 like this.

Share This Page