• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Switch the side of the online indicator

Tracy Perry

Well-known member
#5
And if you are using a custom style (or a child style of a paid style) then you can do a simple template search for that class and change it in the appropriate CSS template for that style... otherwise you would use EXTRA.css
 

DRaver

Active member
#6
I dont get it. I think this is the original code:
Code:
.messageUserBlock div.avatarHolder .onlineMarker
            {
                position: absolute;
                top: {xen:calc '@messageAvatarHolder.padding-top - 1'}px;
                left: {xen:calc '@messageAvatarHolder.padding-right - 1'}px;
              
                @property "messageOnlineMarker";
                border: 7px solid transparent;
                border-top-color: rgb(127, 185, 0);
                border-left-color: rgb(127, 185, 0);
                border-top-left-radius: 5px;
                border-top-right-radius: 3px;
                border-bottom-left-radius: 3px;
                @property "/messageOnlineMarker";
            }
Is it right and what must i change? Sorry, I am not a coder.
 

Brogan

XenForo moderator
Staff member
#7
Change the CSS to match how it is in the screenshot in my post above - essentially left should be right and vice versa.
 

Tracy Perry

Well-known member
#8
It's pretty much self explanatory in that code you gave. It's the TOP and LEFT settings that you need to change.

Code:
.messageUserBlock div.avatarHolder .onlineMarker {
top: -25px;
left: -25px;
}
Try that in your EXTRA.css and you will see it should move it.
 

DRaver

Active member
#9
hehe. I make this code change:

Code:
.messageUserBlock div.avatarHolder .onlineMarker
            {
                position: absolute;
                top:   9 px;
                right: 9 px;
              
                @property "messageOnlineMarker";
                border: 7px solid transparent;
                border-top-color: rgb(127, 185, 0);
                border-left-color: rgb(127, 185, 0);
                border-top-left-radius: 5px;
                border-top-right-radius: 3px;
                border-bottom-left-radius: 3px;
                @property "/messageOnlineMarker";
            }
The Result :

upload_2014-12-28_15-55-14.png
 

DRaver

Active member
#12
I have solved the problem. The problem was, that my own XenForo SEO AddOn Tool "Panda Buster", had problems with the avatar area.
Now its works. Thanks.