Not a bug Swiftmailer no longer maintained from Nov 2021

Sim

Well-known member
Affected version
2.2.5

Xon

Well-known member
The DSN-connection strings yuck. I understand it is to support stringy environmental variables, but is is such a step back from php's increasingly better typing.
 

Sim

Well-known member
The DSN-connection strings yuck. I understand it is to support stringy environmental variables, but is is such a step back from php's increasingly better typing.
Yeah I saw those and had a similar reaction!
 

kick

Well-known member
It does require php 7.2.5+, but hopefully that will be doable by the next feature update of XF
According to @Chris D, 2.3 should have a minimum version of 7.2.
Use the time to make sure your PHP version is as up to date as possible. Minimum has increased again for XF 2.3 (PHP 7.2 will be the minimum) but we recommend PHP 8.0.
Considering that support will end in November, and there is a lot of time before November. the XF team will clearly take everything into account
 

Chris D

XenForo developer
Staff member
We're not classifying this as a bug given that Swiftmailer will of course stay functioning beyond November, but we are aware of it and we will very likely switch to Symfony Mailer in a future version with more details to be announced closer to the time.

Thanks for bringing it to our attention though :)
 
Top