1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Lack of Interest Suggestion: A way of bypassing auto-embedding of URLs

Discussion in 'Closed Suggestions' started by Kevin, Feb 22, 2012.

  1. Kevin

    Kevin Well-Known Member

    Below are three lines of text that were entered into a post....



    [url=http://www.youtube.com/watch?feature=player_embedded&v=OOy-7y5x8y0]http://www.youtube.com/watch?feature=player_embedded&v=OOy-7y5x8y0 [/url]​

    Notice on the 3rd line there is a space before the closing URL tag; that is the only difference between the 2nd & 3rd line. On my test site I have auto-embedding turned on.

    The results I was expecting is that the first line would auto-embed as a YouTube video and that the second & third lines would not auto-embed since I was wrapping them explicitly inside of manual URL tags.

    The results that I got were that the 1st & 2nd line both got auto-embedded while the 3rd line was just a link as expected.

    I was trying to use the URL tags in this fashion so that I could link to a YouTube video as a link showing the full URL but not have it auto-embed itself.

    Suggestion is have a way of bypassing auto-embedding URLs as needed/wanted. Perhaps a 'noembed' tag along the lines of the 'plain' tag?
  2. Mike

    Mike XenForo Developer Staff Member

    Basically auto-embedding will never happen if the URL is different from the text of the link, hence why #3 doesn't embed.

    We can't really disable it for #2 because it's very easy to get links added for your automatically. (It was like this initially and it missed a lot legitimate attempts to embed.)
  3. Kevin

    Kevin Well-Known Member

    How about a 'noembed' wrapper tag? :) Going forward I know personally I can cheat by just putting a space at the end of the link but it might be easier if there was controlling it.
  4. Digital Doctor

    Digital Doctor Well-Known Member

  5. Digital Doctor

    Digital Doctor Well-Known Member

    Test 2 worked fine until I posted the same test, Test3 !
    weird !
  6. Digital Doctor

    Digital Doctor Well-Known Member

  7. Digital Doctor

    Digital Doctor Well-Known Member

  8. Digital Doctor

    Digital Doctor Well-Known Member

    Kevin: just make sure the youtube URL is just the URL and the text of the post is the URL plus one trailing space.
    Worked for me.
    Except when I posted the same link again !
    Then it embedded the first link, but not the second !

Share This Page