1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Staff Members & Header on Profiles

Discussion in 'Styling and Customization Questions' started by raioneru, Apr 29, 2015.

  1. raioneru

    raioneru New Member

    I'm looking to see if someone can point me in the right direction as to what files (or how to do it) would I need to alter to get this two things: first, I want to change the look of the Staff Member banner, and I'm also trying to make it so that user profiles do not show the forum header and notices. One extra question: is it possible to use a img instead of the green online status on user's posts? If someone can at least point me in the right direction I would really appreciate it.

    Thanks
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    The staff member banner can be styled using .userBanner.bannerStaff in EXTRA,css.

    Not entirely sure what you mean but you can edit the template to remove certain content.

    Yes, you can just edit the .messageUserBlock div.avatarHolder .onlineMarker CSS as required.
     
  3. raioneru

    raioneru New Member

    Thank you, that helps a lot. With the first one what I'm trying to do is basically just removing the notice and the header from the user's profile. Basically make it go from this:
    Capture.JPG

    To look like this:
    Capture2.JPG
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    You can achieve that using CSS and display:none using the template name class, which is member_view, or via a conditional statement to remove the logo block for that page only.
     
  5. raioneru

    raioneru New Member

    Great; I think I can go from there, thank you Brogan.

    One last questions, do you know if there is a way to remove it without having to opt out out of "Display user as staff"? Thanks.
     
    Last edited: Apr 29, 2015
  6. raioneru

    raioneru New Member

    So I was able to hide a few things using:

    .member_view .breadBoxTop
    .member_view .scrollContainer
    You can considered me new with all of these, so right now I'm completely stuck, I can't find a way to hide the whole navigation menu on the profile page only. A little help would be greatly appreciated.
     
  7. oO5 Dynasty

    oO5 Dynasty Active Member

    I want to achieve this for some of my members profiles.
    how would i type the code in the extra.cc?
    http://www.oo5dynasty.com/community/upload/index.php?members/grjoker.80/

    I was able to do this with pages, but i cant seem to find out what im suppose to use to remove this stuff from the members profiles.
    Code:
    .node95 .titleBar{
    display: none;
    }
    
    .node95 .titleBar h1{
    display: none;
    }
    
    .node95 #headerProxy{
    display: none;
    }
    
    .node95 #logoBlock {
    display: none;
    }
    
    .node95 .navTabs {
    display: none;
    }
    
    
    .node95 .breadBoxTop,
    .node95 .breadBoxBottom
    {
        display: none;
    }
    
    
    body.node95 {
      margin: 0px;
    }
    
    .node95 #content .pageContent {
    background-color: #000;
    }
    
    
    .node95 #pageNodeContent .bottomContent {
        display: none;
    }
    
    
    
    
    .member_view .breadBoxTop,
    .member_view .breadBoxBottom
    {
        display: none;
    }
     
    Last edited: Jun 5, 2015
  8. Brogan

    Brogan XenForo Moderator Staff Member

    You need to use the correct class based on the template name.

    The FAQ in my signature explains how to identify the name.
     
  9. oO5 Dynasty

    oO5 Dynasty Active Member

    So i read thru your FAQ and i did a View Page source and this is what i found.

    Code:
    <div id="content" class="member_view">
        <div class="pageWidth">
            <div class="pageContent">
                <!-- main content area -->
                
    when i put in
    Code:
    .member_view .breadBoxTop,
    .member_view .breadBoxBottom
    {
        display: none;
    }
    It doesnt take it away.
    So im confused on how to find the name for this members profile, so i can remove stuff.
     
  10. Brogan

    Brogan XenForo Moderator Staff Member

    It works for me in the default style, so either it's a style issue or you have a problem in your EXTRA.css template further up.
    A missing closing bracket or some other malformed code perhaps.
     
  11. oO5 Dynasty

    oO5 Dynasty Active Member

    ok ill go look
     
  12. oO5 Dynasty

    oO5 Dynasty Active Member

    ok so i looked at the extra.cc and found no open { } so i cleared the extra.css and just put in the code.
    Code:
    .member_view .titleBar{
    display: none;
    }
    
    .member_view .titleBar h1{
    display: none;
    }
    
    .member_view #headerProxy{
    display: none;
    }
    
    .member_view #logoBlock {
    display: none;
    }
    
    .member_view .navTabs {
    display: none;
    }
    
    
    .member_view .breadBoxTop,
    .member_view .breadBoxBottom
    {
        display: none;
    }
    
    
    body.member_view {
      margin: 0px;
    }
    



    The only one that worked was the
    Code:
    .member_view .breadBoxTop,
    .member_view .breadBoxBottom
    {
        display: none;
    }


    So it got me to thinking, i didn't have the correct name for that specific page.
    When i look at the source code for both page, they both have the same code
    Code:
    <div id="content" class="member_view">
        <div class="pageWidth">
            <div class="pageContent">
                <!-- main content area -->
              
              
              
              
                          
              
          
              
          
      
    http://www.oo5dynasty.com/community/upload/index.php?members/grjoker.80/
    http://www.oo5dynasty.com/community/upload/index.php?members/oo5-dynasty-™.1/

    So is "member_view" universal for all profiles, or is their a different Name / id for each profile that i can put into the codes to removed the NavTabs and LogoBlock etc. for each profile?
     
  13. Brogan

    Brogan XenForo Moderator Staff Member

    It's the same template for every member.

    It works in my testing.
     
  14. Brogan

    Brogan XenForo Moderator Staff Member

    Off topic, but I see that your site has /upload/ in the URL.

    You can remove that by moving the contents to the community directory on the server.

    When installing XenForo, you should upload the contents of the upload folder, not the folder itself.
     
  15. oO5 Dynasty

    oO5 Dynasty Active Member

    ok cool, i went to the default theme i have and tried to see if it would work. This is what i came up with! The Breadbox is gone but the navTabs etc is still their. Do you think its an add-on that could be messing with things?
    The Logo image is still their in the background and the Navigation Bar is still their.
    upload_2015-6-5_14-21-4.png

    upload_2015-6-5_14-23-30.png
     
  16. oO5 Dynasty

    oO5 Dynasty Active Member

    ok cool, so i just move the files in the ftp. Is it as simple as copy the files in the upload folder and pasting them in the community folder?
     
  17. oO5 Dynasty

    oO5 Dynasty Active Member

    Just wanted to know if it was a copy and past thing cause i dont want to run into issues i probably wont know how to solve.
     

Share This Page