• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
sonnb - Hide Prefixes From UserGroups

sonnb - Hide Prefixes From Guests 1.0.1

No permission to download
Able to hide Threads with specified prefixes from Guest

sonnb

Well-known member
#1
sonnb submitted a new resource:

sonnb - Hide Prefixes From Guests (version 1.0.0) - Able to hide Threads with specified prefixes from Guest

Description:
With this addon, you are able to hide Threads with specified prefixes from Guest. For example: Hide all threads with prefixes enabled from Guests, this is some kind of rules to motivate guests to register.

Addition Information:
Request and Contributed by: 8thos
Read more about this resource...
 

sonnb

Well-known member
#5
sonnb updated sonnb - Hide Prefixes From UserGroups with a new update entry:

Changed from Guest to Usergroup permission

- Changed permission from default for guests to Usergroups. If you want to hide prefixes for specified usergroups (assuming for guests), go to that usergroup permission and enable "Cannot see Guest prefixes".
- Changed addon's name from "Hide Prefixes From Guests" to "Hide Prefixes From UserGroups".
- Changed addon's directory structure from "sonnbHidePrifixesFromGuests" to "sonnb/HidePrefixes".

It's recommended for you to delete old addon's folder after update.
Read the rest of this update entry...
 

DRE

Well-known member
#6
Just an update, it didn't make my message for guests activity break. It was ragtek's multi-moderation tools that made it break. So if any of you use that modification just know it will screw up the message for guests. My solution was to uninstall multi-moderation for now. Anyway this is probably one of my top 5 modifications on the site at the moment. It made user activity on my site jump up a notch because now they know they have to sign in just to read a certain thread or two.
 

sonnb

Well-known member
#9
Hey this usergroup permission isn't working
Please download new file as old file has wrong callback in option. How do you set the permission? You have to set to "Allow" for this permission to hide prefixes from that usergroup.
 

DRE

Well-known member
#10
Please download new file as old file has wrong callback in option. How do you set the permission? You have to set to "Allow" for this permission to hide prefixes from that usergroup.
Yes I did. I redownloaded and even re-uploaded. I made sure Unregistered/Unconfirmed were checked either as 'No' or 'Revoked' (tried both ways) for the Cannot see Guest Prefixes: Usergroup Permission and it is still letting guests see the thread.
 

DRE

Well-known member
#13
Hi. Here's a bug. When a guests clicks on a hide prefix from guests thread, they get this message: A server error occurred. Please try again later.

 
#15
Is there a way to get this to work for only like the top level group someone is in? Like if I'm in Registered and Moderator groups, it would ignore the Registered group's permissions?
 

sonnb

Well-known member
#16
Is there a way to get this to work for only like the top level group someone is in? Like if I'm in Registered and Moderator groups, it would ignore the Registered group's permissions?
This is built-in XF behavior. Just go to Moderator's Group Permission and set "ignore" for this permission, it would override all other group permissions that user currently in.
 
#18
I've noticed you can still see the posts, or at least the first couple lines of the post, in Members > Recent Activity and Forums > What's New?
Any way to block that as well?
 
#20
Thanks for making this, i was able to make it work as a way of hiding certain prefixes from members under 18, or members who have set a custom field for maturity filter to "Enabled." excellent stuff!