1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 [solved] SSH upgrade stall/memory error

Discussion in 'Installation, Upgrade, and Import Support' started by Live Free, Nov 8, 2014.

  1. Live Free

    Live Free Active Member

    Hi,

    I'm in the middle of upgrading from 1.3.5 to 1.4.

    Took a backup, upload the files, began the upgrade via url. Gave me a php command to run via ssh. I ran it. Ran smoothly until it began upgrading to 1.4.2 step 1. It completed that. Began rebuilding/ importing data. Began rebuilding.... templates. Then:

    Code:
    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 15064 bytes) in /home/admin/public_html/library/Zend/Db/Statement/Mysqli.php on line 276
    I then get the ssh ~~ space notification when nothing's happening or something's completed, but it doesn't look like it made it through the entire installation. When I view the admin.php it says "The board is currently waiting to be upgraded. Please complete the upgrade."

    I am then presented with the same command that I already tried to run.

    What's the current status of my installation? Should I re-run the command? Wait?

    Thank you.
     
  2. Mike

    Mike XenForo Developer Staff Member

    You can re-run that command. Normally the rebuild shouldn't take a ton of memory, but disable debug mode if you have it set.

    At this point, running the upgrade via the web interface will be fine too.
     
    Liam W likes this.
  3. Live Free

    Live Free Active Member

    Thanks. Re-ran it and it worked. Just wanted to make sure I wasn't going to make the issue worse (while trying to balance acceptable downtime). Thanks, upgrade completed. :D
     

Share This Page