1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 SMTP Connection Refused?

Discussion in 'XenForo Questions and Support' started by EternaL, Aug 2, 2016.

  1. EternaL

    EternaL New Member

    Hi, I'm using Office 365 as my SMTP server because godaddys default email handler is too slow. All the SMTP information is correct but I keep getting a connection refused error.... And I called the host they said it shouldn't be happening here are the error logs if someone could help me that'd be awesome!

    Code:
    Zend_Mail_Protocol_Exception: Email to blueberrygw2@gmail.com failed: Connection refused - library/Zend/Mail/Protocol/Abstract.php:277
    Generated By: EternaL, A moment ago
    Stack Trace
    
    #0 /home/blueberrysky/public_html/library/Zend/Mail/Protocol/Smtp.php(167): Zend_Mail_Protocol_Abstract->_connect('ssl://smtp.offi...')
    #1 /home/blueberrysky/public_html/library/Zend/Mail/Transport/Smtp.php(216): Zend_Mail_Protocol_Smtp->connect()
    #2 /home/blueberrysky/public_html/library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Smtp->_sendMail()
    #3 /home/blueberrysky/public_html/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
    #4 /home/blueberrysky/public_html/library/XenForo/Mail.php(175): Zend_Mail->send(Object(Zend_Mail_Transport_Smtp))
    #5 /home/blueberrysky/public_html/library/XenForo/Mail.php(152): XenForo_Mail->sendMail(Object(Zend_Mail))
    #6 /home/blueberrysky/public_html/library/XenForo/Model/UserConfirmation.php(191): XenForo_Mail->send('blueberrygw2@gm...', 'shadow')
    #7 /home/blueberrysky/public_html/library/XenForo/ControllerAdmin/User.php(949): XenForo_Model_UserConfirmation->processUserModeration(Array, 'approve', true, '')
    #8 /home/blueberrysky/public_html/library/XenForo/FrontController.php(351): XenForo_ControllerAdmin_User->actionModeratedUpdate()
    #9 /home/blueberrysky/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #10 /home/blueberrysky/public_html/admin.php(13): XenForo_FrontController->run()
    #11 {main}
    
    Request State
    
    array(3) {
      ["url"] => string(61) "https://www.wantedheroes.org/admin.php?users/moderated/update"
      ["_GET"] => array(1) {
        ["users/moderated/update"] => string(0) ""
      }
      ["_POST"] => array(2) {
        ["users"] => array(1) {
          [169] => array(2) {
            ["action"] => string(7) "approve"
            ["notify"] => string(1) "1"
          }
        }
        ["_xfToken"] => string(8) "********"
      }
    }
    
    
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

  3. Mike

    Mike XenForo Developer Staff Member

    I would definitely double check the SMTP settings you entered -- the port specifically.

    There is a possibility that your host is explicitly blocking outgoing connections on that port; this practice has certainly been common on residential connections, for example. If there are alternate ports you can use, try them.
     
    Sachin Tiwari likes this.
  4. Sachin Tiwari

    Sachin Tiwari New Member

    Agreed with @Mike. Most of the hosting provider explicitly block the outgoing SMTP ports. Try port 2525 if that works. Else try connecting with your hosting provider to unblock port 25, 587, 2525 for outgoing SMTP connections.
     

Share This Page