• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Smileys - can't activate them

Izze

New member
#1
Hi,

yesterday after fresh installation and vB4 import I imported 480 smileys with xml method.
I used a script that creates a xml import file out of a directory with smileys on the pc.

After I imported them they were all active. But the script set all sizes to 18x18. This was to small so I deactivated them and want to reload them.
Now I have the problem, I cant only activate 7 smilieys. After that I get the error message (The server responded with an error. The error message is in the JavaScript console.) on the screenshot below.

How can I activate all my smileys and show them in the correct size when they are bigger than 18x18?

Otherwise, how do I delete all of them and reinstall just the original Smileys without klicking 490+ times on the delete button?

Thanks for help!
 

Attachments

Brogan

XenForo moderator
Staff member
#2
Open the browser dev tools and select the console tab.

That will then give a detailed error message.
 

Izze

New member
#3
Hmm, OK, hope this is what you need:
Code:
XenForo.activate(%o) [object HTMLDocument] xenforo.js:220
"XenForo.FilterList " Object { length: 0, prevObject: Object, context: <ul.FilterList>, selector: "input[name="filter"]" } filter_list.js:8:16
"XenForo.init() 787ms. jQuery 1.11.0/1.2.8-dev" xenforo.js:209:168
"PHP <!DOCTYPE html>
<html id="XenForo" lang="de-DE" dir="LTR" class="Admin RunDeferred">
<head>
    <meta charset="utf-8" />
    <meta name="robots" content="noindex" />
    <meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />
    <title>Fehler | Admin CP - NERA</title>

    <noscript><style>.JsOnly { display: none !important; }</style></noscript>
    <link rel="stylesheet" href="admin.php?_css/&amp;css=public%3Axenforo%2Cpublic%3Aform%2Cadmin%2Cheader%2Cfooter&amp;dir=LTR&amp;d=1430558273" />
  
    <link rel="stylesheet" href="admin.php?_css/&amp;css=genesis&amp;dir=LTR&amp;d=1430558273" />


    <script src="js/jquery/jquery-1.11.0.min.js"></script>
<script src="js/xenforo/xenforo.js?_v=7d9c8323"></script>
<script src="js/xenforo/acp_quicksearch.js?_v=7d9c8323"></script>

<script>

jQuery.extend(true, XenForo,
{
    serverTimeInfo: { now: 1430560991, today: 1430517600, todayDow: 6 },
    _enableOverlays: "1",
    _animationSpeedMultiplier: "1",
    _overlayConfig:
    {
        top: "10%",
        speed: 200,
        closeSpeed: 100,
        mask:
        {
            color: "rgb(255, 255, 255)",
            opacity: "0.6",
            loadSpeed: 200,
            closeSpeed: 100
        }
    },
    _loadedScripts: {"genesis":true,"js\/xenforo\/sidebar.js?_v=7d9c8323":true},
    _cookieConfig: { path: "/", domain: "", prefix: "xf_"},
    _csrfToken: "1,1430560991,80e3ac96ec4ecbf40016e26142011f05dee6307e",
    _csrfRefreshUrl: "admin.php?login/csrf-token-refresh",
    _jsversion: "7d9c8323",
    _manualDeferUrl: "admin.php?tools/run-deferred"
});

jQuery.extend(XenForo.phrases,
{
    cancel: "Abbrechen",

    a_moment_ago:    "Vor einem Moment",
    one_minute_ago:  "Vor einer Minute",
    x_minutes_ago:   "Vor %minutes% Minuten",
    today_at_x:      "Heute um %time% Uhr",
    yesterday_at_x:  "Gestern um %time% Uhr",
    day_x_at_time_y: "%day% um %time% Uhr",

    day0: "Sonntag",
    day1: "Montag",
    day2: "Dienstag",
    day3: "Mittwoch",
    day4: "Donnerstag",
    day5: "Freitag",
    day6: "Samstag",

    _months: "Januar,Februar,März,April,Mai,Juni,Juli,August,September,Oktober,November,Dezember",
    _daysShort: "So,Mo,Di,Mi,Do,Fr,Sa",

    following_error_occurred: "Folgende Fehler sind aufgetreten",
        server_did_not_respond_in_time_try_again: "Der Server antwortet nicht. Bitte versuche es noch einmal.",
    click_image_show_full_size_version: "Klicke auf dieses Bild, um es in vollständiger Größe anzuzeigen.",
    no_items_matched_your_filter: "Es wurde kein Element gefunden, das mit dem Filter übereinstimmt.",
    processing: "Bearbeitung",
    cancel: "Abbrechen",
    cancelling: "Breche ab"
});

</script>
        <script src="js/xenforo/sidebar.js?_v=7d9c8323"></script>

  
  
  
</head>
<body data-controller="XenForo_ControllerAdmin_Smilie::actionToggle; ">



<div id="header">

    <div id="logoLine">
        <div class="pageWidth">
            <a href="http://xenforo.com" target="XenForo"><img src="styles/default/xenforo/XenForo-small.png" id="logo" /></a>
            <h2 id="version"><a href="http://xenforo.com" target="XenForo">XenForo</a> 1.4.6</h2>
            <a href="admin.php?login/logout&amp;_xfToken=1%2C1430560991%2C80e3ac96ec4ecbf40016e26142011f05dee6307e" id="logoutLink">Izze abmelden</a>
        </div>
    </div>
  
    <div id="tabsNav">
        <div class="pageWidth">
            <ul class="acpTabs">
              
                    <li class="active"><a href="admin.php">Startseite</a></li>
              
                    <li><a href="admin.php?applications/">Anwendungen</a></li>
              
                    <li><a href="admin.php?users/">Benutzer</a></li>
              
                    <li><a href="admin.php?appearance/">Erscheinungsbild</a></li>
              
                    <li><a href="admin.php?tools/">Werkzeuge</a></li>
              
                <li class="separated Popup" id="AdminSearch">
                    <a rel="menu" class="PopupClosed" accesskey="f"> Suche</a>
                    <div class="Menu" id="AdminSearchMenu">
                      
            <form action="admin.php?search/" id="AdminSearchForm" data-target="#AdminSearchResults" method="post" class="xenForm formOverlay">
                            <label><!-- Suche: --><input type="search" name="q" value="" results="0" class="textCtrl" id="AdminSearchInput" /></label>
                        <input type="hidden" name="_xfToken" value="1,1430560991,80e3ac96ec4ecbf40016e26142011f05dee6307e" />
</form>
      
                        <div id="AdminSearchResults"></div>
                    </div>
                </li>
                <li class="separated"><a href="index.php" target="_blank">NERA</a></li>
            </ul>
        </div>
        <div class="pad"></div>
    </div>
  
</div>
    <script>
       jQuery(document).ready(function($){
          $(window).bind('scroll', function() {
             var navHeight = ($(window).scrollTop());
             if (navHeight > $('#header').outerHeight()) {
                $('#sideNav').removeClass('unFix');
                    $('#sideNav').css('margin-top', "-" + $('#header').outerHeight() + "px");
             } else {
                $('#sideNav').addClass('unFix');
                    $('#sideNav').css('margin-top', 0);
             }
           });
       });
    </script>


<div id="body" class="pageWidth">

    <div id="contentContainer">
  
        <div id="content">
            <noscript><p class="importantMessage">Die XenForo Administration benötigt JavaScript. Bitte aktiviere dies, bevor du fortsetzt. </p></noscript>

            <!--[if lt IE 8]>
                <p class="importantMessage">Du verwendest einen veralteten Browser. Dieser kann eventuell diese oder andere Webseiten nicht richtig darstellen.<br />Du solltest deinen Browser aktualisieren oder einen <a href="http://www.browserchoice.eu/BrowserChoice/browserchoice_de.htm" target="_blank">alternativen Browser</a> verwenden.</p>
            <![endif]-->

          

            <div id="breadcrumbsContainer">
    <ul id="breadcrumbs">
      
              
                    <li><a href="admin.php">Startseite</a></li>
              
                    <li><a href="admin.php?smilies/">Smileys verwalten</a></li>
              
      
      
    </ul>
</div>
          
<div class="titleBar">
  
    <h1>Fehler</h1>
  
</div>
      
          

<div class="errorOverlay">
    <a class="close OverlayCloser"></a>
  
      
      
        <div class="baseHtml">
      
            <label for="ctrl_0" class="OverlayCloser">Ein Sicherheitsfehler ist aufgetreten. Bitte aktualisiere die Seite und und versuche es erneut.</label>
      
        </div>
  
</div>
        </div>
  
      

<div id="footer">
  

    <div id="copyright">
        <a href="https://xenforo.com" class="concealed">Forum software by XenForo&trade; <span>&copy;2010-2015 XenForo Ltd.</span></a>
      
    </div>
</div>
      
    </div>
  
  
    <ul id="sideNav" class="FixedSidebar">
      
            <li class="sideNavSection"><a>Einstellungen / Installation</a>

    <ul>
        <li class="sideNavLink"><a href="admin.php?options/">Einstellungen verwalten</a>

</li><li class="sideNavLink"><a href="admin.php?help-pages/">Hilfeseiten verwalten</a>

</li><li class="sideNavLink"><a href="admin.php?route-filters/">Route Filter verwalten</a>

</li>
    </ul>

</li>
      
            <li class="sideNavSection"><a href="admin.php?notices/">Informationssystem</a>

    <ul>
        <li class="sideNavLink"><a href="admin.php?notices/">Informationen verwalten</a>

</li>
    </ul>

</li>
      
            <li class="sideNavSection"><a>BBCode &amp; Smileys</a>

    <ul>
        <li class="sideNavLink"><a href="admin.php?bb-codes/">BBCodes verwalten</a>

</li><li class="sideNavLink"><a href="admin.php?bb-code-media-sites/">Medienseiten verwalten</a>

</li><li class="sideNavLink"><a href="admin.php?smilies/">Smileys verwalten</a>

</li>
    </ul>

</li>
      
            <li class="sideNavSection"><a href="admin.php?add-ons/">Add-ons</a>

    <ul>
        <li class="sideNavLink"><a href="admin.php?add-ons/">Add-ons verwalten</a>

</li><li class="sideNavLink"><a href="admin.php?add-ons/install-upgrade">Installieren &amp; Aktualisieren</a>

</li><li class="sideNavLink"><a href="admin.php?add-ons/update-check">Aktualisierungen [0]</a>

</li>
    </ul>

</li>
      
    </ul>

</div>

</body>
</html>" xenforo.js:231:168

XenForo.activate(%o) [object Object]
 

Izze

New member
#5
Does this limit also exist when I enable them one after one by hand?
After the 7th smiley I can't activate the 8th or more. I activate the hook in the box and when I reach box 8 its over.
 

Mike

XenForo developer
Staff member
#6
If you're talking about enabling them on the smiley list (with all of them), then it does likely apply. You should be able to enable them by editing them individually.
 

Izze

New member
#7
OK, did the hard way, deleted the content of "xf_smilie" with phpMyAdmin.
The used Smiley Manager to import everything new.

I don't tested that I can activate/deactivate them again. They are all activated and thats what I want.
Maybe the Java or whatever error ist still there.

Thanks for your help!
 

Tracy Perry

Well-known member
#8
Odds are the issue will still be there @Izze. This was a problem that turned up (along with some other weird issues) when myself and some others I know got a "few" more smilies than what most use. The max_input_vars that Mike indicated was what I found fixed my (and the others) issues. The other place it turned up was on trying to re-arrange them.