XF 2.1 Site Down: This Error


Hi there,

My has recently gone down and the error log is filling up with the message every 20-30 seconds.

I've not changed anything and I'm the only person with access.

Afraid I have no idea what League/Flysystem relates to.

Any ideas what could have caused this and, more importantly, what can be down to fix it?

My page goes blank when I try to access the site.

(Also, I'm not very technical....I just wanted a discussion forum on my site, and installed it.)

[10-Feb-2022 18:48:47 UTC] PHP Fatal error: Uncaught Error: Class "League\Flysystem\Adapter\Local" not found in /home3/accountname/public_html/mysite/forum/src/XF/LocalFsAdapter.php:5
Stack trace:
#0 /home3/accountname/public_html/mysite/forum/src/vendor/composer/ClassLoader.php(444): include()
#1 /home3/accountname/public_html/mysite/forum/src/vendor/composer/ClassLoader.php(322): Composer\Autoload\includeFile('/home3/mcabney1...')
#2 /home3/accountname/public_html/mysite/forum/src/XF/FsMounts.php(146): Composer\Autoload\ClassLoader->loadClass('XF\\LocalFsAdapt...')
#3 /home3/accountname/public_html/mysite/forum/src/XF/FsMounts.php(21): XF\FsMounts::getLocalAdapter('data')
#4 /home3/accountname/public_html/mysite/forum/src/XF/App.php(1043): XF\FsMounts::loadDefaultMounts(Array)
#5 /home3/accountname/public_html/mysite/forum/src/XF/Container.php(28): XF\App->XF\{closure}(Object(XF\Container))
#6 /home3/accountname/public_html/mysite/forum/src/XF/App.php(2423): XF\Container->offsetGet('fs')
#7 /home3/accountname/public_html/mysite/forum/src/XF.php(699): XF\App->fs()
#8 /home3/accountname/public_html/mysite/forum/src/XF/Util/File.php(728): XF::fs()
#9 /home3/accountname/public_html/mysite/forum/src/XF/Error.php(100): XF\Util\File::installLockExists()
#10 /home3/accountname/public_html/mysite/forum/src/XF/App.php(2202): XF\Error->logException(Object(ErrorException), true, '')
#11 /home3/accountname/public_html/mysite/forum/src/XF.php(207): XF\App->logException(Object(ErrorException), true)
#12 [internal function]: XF::handleFatalError()
#13 {main}
thrown in /home3/accountname/public_html/mysite/forum/src/XF/LocalFsAdapter.php on line 5
Last edited:


All that's on that page is:


$phpVersion = phpversion();
if (version_compare($phpVersion, '5.6.0', '<'))
die("PHP 5.6.0 or newer is required. $phpVersion does not meet this requirement. Please ask your host to upgrade PHP.");

$dir = DIR;
require($dir . '/src/XF.php');



That happened once before with an vBulletin board, which is when I made the switch to XenForo.

I should have added these details at the start. Host states:

Apache Version2.4.52
PHP Version7.3.33
MySQL Version5.7.23-23

I reckon these are okay as I was able to install, as a test, a new forum on a subdirectory
Last edited:


So, returning the main complaint of the error:
PHP Fatal error: Uncaught Error: Class "League\Flysystem\Adapter\Local" not found in /home3/accountname/public_html/mysite/forum/src/XF/LocalFsAdapter.php:5

The posts above talk about S3 and DO spaces (not too sure what they are) but the forum was running fine until yesterday, when the change was reported.

To follow up on my post above, on the test forum, I change the new database, username, and password to the normal one, hoping to effectively redirect the install there (and then just rename the folders, in the hope that everything went okay), but that produced a page saying an upgrade was in process, even though the forum was the latest version.


It's been a couple of days and I'm still no closer to a solution.

As I can't see the website, I can't log into the admin panel. I can only view the error logs in the File Manager and explore the files, but can't interact with the front end.


XenForo moderator
Staff member
I would say to run a a file health check in the ACP but admin.php is reporting a web server 500 error.
Ask your host to check the server error logs for the cause of that.

You can try downloading the upgrade archive for the version you are currently running and uploading the files again, to see if that resolves it.

It's worth pointing out that a working installation would never randomly fail in this manner.
It would have to be something at the server which changed to cause it.
  • Like
Reactions: WLF


Thanks all for taking the time to respond.

The issue is resolved now. Looks like an installation of a Wordpress on a subfolder rewrote .htaccess file.for PHP 8. Reverting to PHP 7 fixed it.