XF 1.5 Site down after 1.5.13 upgrade due to addon. Cant disable it.

Alfa1

Well-known member
After uploading XF 1.5.13 files, the addon DragonByte Security took down my site. This error is on my site:
Code:
 Parse error: syntax error, unexpected '[' in /library/DBTech/Security/XenForo/Session.php on line 38
I tried reuploading 1.5.12 files, but this didnt help.

When I disable listeners I can get the site to load again, but when I try to deactivate the addon I get this error in the console:
Code:
PHP <br />
<b>Parse error</b>:  syntax error, unexpected '[' in <b>/library/DBTech/Security/XenForo/Install/Uninstall.php</b> on line <b>61</b><br />
So I cannot disable the addon.

Is there any other way to disable an addon?
Would it be wise to just keep listeners off, then upgrade and then turn listeners on again?

@DragonByte Tech is not online. I have 5000 people trying to get on my site.
 

Chris D

XenForo developer
Staff member
I notice that add-on states the minimum requirements are:
XenForo v1.5.3+, PHP 5.6+
The parse error is tripping up on the [ character.
Code:
[]
is often used as the array construct in later PHP versions (since PHP 5.4) rather than
Code:
array()
So the error is suggesting you're no longer running PHP 5.4.

What version of PHP are you currently running?
 

Alfa1

Well-known member
I found it. It was not the addon, but a matter of uploading the default xf .htaccess file which overwrites our .htaccess file and thus the adhandler.

The htaccess file in the package should really not be in a format that overwrites the root htaccess.

Thanks for your swift support!
 

Chris D

XenForo developer
Staff member
The .htaccess file isn't included in the upgrade package, so maybe you downloaded the full version?
 
Top