1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Show forum list on root

Discussion in 'XenForo Questions and Support' started by ideatic, Sep 5, 2015.

  1. ideatic

    ideatic New Member

    Hi, I have installed xenForo on the root of a subdomain (Foro Comuniame) but every time I access that URL the browser redirects me to /forums (/foros after Route filter). How can I show the forum list without this redirect?

    Thank you
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Do you have any rewrites in the .htaccess file in the directory or implemented on the server?
  3. ideatic

    ideatic New Member

    No, this is my .htaccess:

    <IfModule mod_rewrite.c>
        RewriteEngine On
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        #RewriteBase /xenforo
        #    This line may be needed to enable WebDAV editing with PHP as a CGI.
        #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
  4. Brogan

    Brogan XenForo Moderator Staff Member

    What do you have in the find and replace fields for the route filter?

    It should be forums/ and foros/.
  5. ideatic

    ideatic New Member

    Yes, they are
  6. ideatic

    ideatic New Member

    I solved it, I was setting the "Index Page Route" option to "/foros".

    Sorry for the inconvenience

Share This Page