1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Show advertisements, but allow users to buy an upgrade to avoid them

Discussion in 'Styling and Customization Questions' started by DennisSkov, Sep 2, 2015.

  1. DennisSkov

    DennisSkov Active Member

    Aloha, peeps

    So, I recently was kicked out from home, I'm soon going to be fired (not actually fired, there's just no more work to be done after November 1st), so I need to think about where and how I spend my money. It sounds worse than it really is. I've always been a little against advertisements. Don't ask me why because I can't give a proper answer.
    However, as my situation is right now, I've come to the solution that I can't keep my forum online myself. My XenForo license is not active anymore, and my webserver soon needs to be renewed.

    I want to have advertisements show on the forum. However, users should be able to buy an upgrade which disables the advertisements (pay to remove the advertisements + a few other features). How would I do this? Bear in mind that I've never used advertisements in any way before, I have no clue on how to do anything regarding ads.

    Any help is much appreciated! :)
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Create a new user group and a user group promotion which members will be added to when they purchase the upgrade.

    Wrap the ad code in a conditional statement so they don't show to members of that user group.

    These guides should help:
    Conditional Statements
    Responsive AdSense
    DennisSkov likes this.
  3. DennisSkov

    DennisSkov Active Member


    Thanks for the links, Brogan. Right now I'm just trying to get the ads working on the site, but I'm having some issues. After implementing one of the ad codes in a template (ad_thread_list_below_stickies in this example), I can see that the ad now has a place, but it's just white. It doesn't seem like anything is loading.

    As I said, I'm new to advertising... :)

    Is this because I recently signed up for AdSense? Does Google need to go through the website or something like that to verify something?
  4. Brogan

    Brogan XenForo Moderator Staff Member

    If you have just created your adsense account, it can take some time for the ads to start displaying.

    If there is a blank square then that essentially means it's working.
  5. DennisSkov

    DennisSkov Active Member

    Great, thanks for the help. For now I'll just wait :)
  6. DennisSkov

    DennisSkov Active Member

    Great, everything is working. Thanks for the help, @Brogan!

Share This Page