1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Server Errors

Discussion in 'Troubleshooting and Problems' started by PumpinIron, Jul 25, 2016.

  1. PumpinIron

    PumpinIron Active Member

    I'm getting a few server errors being logged in the admin section. Here's what they look like:

    Screen Shot 2016-07-25 at 9.00.03 AM.png

    One says "User tjforum_admin has more than 'max_user_connections' active connections"

    Screen Shot 2016-07-25 at 9.00.14 AM.png

    The next one says "Resource temporarily unavailable"

    Screen Shot 2016-07-25 at 9.00.27 AM.png

    Not even sure where to start with these, so I'm hoping you guys might have an idea, or maybe you've seen this before?
     
  2. PumpinIron

    PumpinIron Active Member

  3. Brogan

    Brogan XenForo Moderator Staff Member

    The max connections is a limitation imposed by your host.

    It could be that it is particularly low, or it could be due to some sort of DDoS/flooding, or an add-on causing it.

    The second error is related to the same issue.
     
    PumpinIron likes this.
  4. PumpinIron

    PumpinIron Active Member

    Got it. I've got a dedicated server so I may be able to fix this myself without calling up the hosting company.

    Is this something that would be found in the php.ini file I assume?
     
  5. Brogan

    Brogan XenForo Moderator Staff Member

    It's a MySQL variable so it would typically be in my.cnf.
     
    PumpinIron likes this.
  6. PumpinIron

    PumpinIron Active Member

    Found it in WHM through the PHP Configuration editor settings. I changed it from 128 to 256. We will see if that fixes the issue.

    Screen Shot 2016-07-25 at 9.13.07 AM.png

    As always, thanks for your prompt response, and your help!
     
  7. Tracy Perry

    Tracy Perry Well-Known Member

    Not sure.. but if it's a PHP option you changed, it won't effect it. That is a DB error from MySQL telling you that there are more connection attempts than the variable in my.cnf is configured for.
    The variable is the max_connections one, and the my.cnf should either be located at /etc/my.cnf or /etc/mysql/my.cnf (typically).
    This could be due to a lot of valid traffic, or a typical WordPress DDOS attack.
     

Share This Page