• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Server Errors after users registered

mauzao9

Well-known member
#1
Heya there.

Today we got around 150 New Users (4 hours) and something i notice as i usually follow the users that just registered, is that it started to return me Server Error sometimes i tried to Follow them.

Not sure if this is related with me following people right after they register, but did never happen before.
Code:
Error Info
Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Duplicate entry '1-1081' for key 'PRIMARY' - library/Zend/Db/Statement/Mysqli.php:214
Generated By: Max Bacon, 18 minutes ago
Stack Trace
#0 /home/bacon/www/www/library/Zend/Db/Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)
#1 /home/bacon/www/www/library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
#2 /home/bacon/www/www/library/Zend/Db/Adapter/Abstract.php(574): Zend_Db_Adapter_Abstract->query('INSERT INTO `xf...', Array)
#3 /home/bacon/www/www/library/XenForo/DataWriter.php(1624): Zend_Db_Adapter_Abstract->insert('xf_user_follow', Array)
#4 /home/bacon/www/www/library/XenForo/DataWriter.php(1613): XenForo_DataWriter->_insert()
#5 /home/bacon/www/www/library/XenForo/DataWriter.php(1405): XenForo_DataWriter->_save()
#6 /home/bacon/www/www/library/XenForo/Model/User.php(1765): XenForo_DataWriter->save()
#7 /home/bacon/www/www/library/XenForo/ControllerPublic/Member.php(473): XenForo_Model_User->follow(Array)
#8 /home/bacon/www/www/library/XenForo/FrontController.php(347): XenForo_ControllerPublic_Member->actionFollow()
#9 /home/bacon/www/www/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#10 /home/bacon/www/www/index.php(13): XenForo_FrontController->run()
#11 {main}
Request State
array(3) {
  ["url"] => string(126) "http://----/members/zehdemonicwolf34.1081/follow?_xfToken=1%2C1411168175%2C9d3c553f480cfc86877bd4a346ce7cb783d24606"
  ["_GET"] => array(1) {
    ["_xfToken"] => string(53) "1,1411168175,9d3c553f480cfc86877bd4a346ce7cb783d24606"
  }
  ["_POST"] => array(5) {
    ["_xfConfirm"] => string(1) "1"
    ["_xfRequestUri"] => string(1) "/"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
    ["_xfResponseType"] => string(4) "json"
  }
}
 

Mike

XenForo developer
Staff member
#2
It's not related to the registration. It's when you followed them and it's a race condition where you attempted to follow them twice. It can be disregarded.
 

mauzao9

Well-known member
#3
Oh that may be why, i'm noticing today my mouse is double clicking sometimes when i just make 1 click, so that's what caused the server error!