• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 Server error when restoring a spam cleaned member

Stuart Wright

Well-known member
#1
Admin Control Panel - AVForums
Server Error
Mysqli statement execute error : Duplicate entry '20611703' for key 'PRIMARY'

  1. Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
  2. Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
  3. Zend_Db_Adapter_Abstract->query() in XenDebug/Db/Mysqli.php at line 13
  4. XenDebug_Db_Mysqli->query() in Zend/Db/Adapter/Abstract.php at line 574
  5. Zend_Db_Adapter_Abstract->insert() in XenForo/DataWriter.php at line 1624
  6. XenForo_DataWriter->_insert() in XenForo/DataWriter.php at line 1613
  7. XenForo_DataWriter->_save() in XenForo/DataWriter.php at line 1405
  8. XenForo_DataWriter->save() in AVForums/ModCheckpoint/DataWriter/DiscussionMessage/Post.php at line 38
  9. AVForums_ModCheckpoint_DataWriter_DiscussionMessage_Post->_messagePostSave() in XenForo/DataWriter/DiscussionMessage.php at line 590
  10. XenForo_DataWriter_DiscussionMessage->_postSave() in XenForo/DataWriter.php at line 1409
  11. XenForo_DataWriter->save() in DigitalPointSpy/DataWriter/DiscussionMessage/Post.php at line 7
  12. DigitalPointSpy_DataWriter_DiscussionMessage_Post->save() in XenForo/Model/InlineMod/Post.php at line 654
  13. XenForo_Model_InlineMod_Post->_updatePostsMessageState() in XenForo/Model/InlineMod/Post.php at line 213
  14. XenForo_Model_InlineMod_Post->undeletePosts() in XenForo/SpamHandler/Post.php at line 59
  15. XenForo_SpamHandler_Post->restore() in XenForo/Model/SpamCleaner.php at line 114
  16. XenForo_Model_SpamCleaner->restore() in XenForo/ControllerAdmin/SpamCleaner.php at line 52
  17. XenForo_ControllerAdmin_SpamCleaner->actionRestore() in XenForo/FrontController.php at line 347
  18. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  19. XenForo_FrontController->run() in /home/sites/avforums/public_html/admin.php at line 13
Any ideas?
 

Liam W

Well-known member
#3
Looks like an issue with a 'ModCheckPoint' addon...

EDIT: Or it could be an issue with the other 2 addons. I don't usually see multiple proxy classes in a server error!

Liam