XF 2.1 Server error log

AzH

Member
Anyone got any idea what this means? Running xF v2.1.10 Patch 2 and only one add-on [8WR] XenPorta 2 (Portal) PRO 2.0.2.5. Default theme with no template modifications.




Code:
ErrorException: Template error: Method canLike is not callable on the given object (XF\Entity\Post) src/XF/Template/Templater.php:994
Generated by: Al Jul 5, 2020 at 11:08 AM
Stack trace
#0 [internal function]: XF\Template\Templater->handleTemplateError(512, 'Method canLike ...', '/home2/strathb1...', 994, Array)
#1 src/XF/Template/Templater.php(994): trigger_error('Method canLike ...', 512)
#2 internal_data/code_cache/templates/l1/s1/public/EWRporta_article_macros.php(187): XF\Template\Templater->method(Object(XF\Entity\Post), 'canLike', Array)
#3 src/XF/Template/Templater.php(701): XF\Template\Templater->{closure}(Object(XF\Template\Templater), Array, Array)
#4 internal_data/code_cache/templates/l1/s1/public/EWRporta_article_view.php(94): XF\Template\Templater->callMacro('EWRporta_articl...', 'article_post', Array, Array)
#5 src/XF/Template/Templater.php(1315): XF\Template\Templater->{closure}(Object(XF\Template\Templater), Array)
#6 src/XF/Template/Templater.php(1388): XF\Template\Templater->renderTemplate('EWRporta_articl...', Array)
#7 internal_data/code_cache/templates/l1/s1/public/thread_view.php(237): XF\Template\Templater->includeTemplate('public:EWRporta...', Array)
#8 src/XF/Template/Templater.php(1315): XF\Template\Templater->{closure}(Object(XF\Template\Templater), Array)
#9 src/XF/Template/Template.php(24): XF\Template\Templater->renderTemplate('thread_view', Array)
#10 src/XF/Mvc/Renderer/Html.php(48): XF\Template\Template->render()
#11 src/XF/Mvc/Dispatcher.php(458): XF\Mvc\Renderer\Html->renderView('XF:Thread\\View', 'public:thread_v...', Array)
#12 src/XF/Mvc/Dispatcher.php(440): XF\Mvc\Dispatcher->renderView(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#13 src/XF/Mvc/Dispatcher.php(400): XF\Mvc\Dispatcher->renderReply(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#14 src/XF/Mvc/Dispatcher.php(58): XF\Mvc\Dispatcher->render(Object(XF\Mvc\Reply\View), 'html')
#15 src/XF/App.php(2190): XF\Mvc\Dispatcher->run()
#16 src/XF.php(391): XF\App->run()
#17 index.php(20): XF::runApp('XF\\Pub\\App')
#18 {main}
Request state
array(4) {
  ["url"] => string(81) "/index.php?threads/command-conquer%E2%84%A2-remastered-collection-now-on-sale.10/"
  ["referrer"] => string(119) "https://strategygaming.net/index.php?threads/command-conquer%E2%84%A2-remastered-collection-now-on-sale.10/article-edit"
  ["_GET"] => array(1) {
    ["threads/command-conquer™-remastered-collection-now-on-sale_10/"] => string(0) ""
  }
  ["_POST"] => array(0) {
  }
}
 

AzH

Member
Nothing I can see. The only thing I’ve added is a html widget on the front page which displays only to guests. This uses the !$xf.visitor.user_id display condition. Nothing else of note.
 
Top