1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Server Error Log: csrf-token-refresh

Discussion in 'Troubleshooting and Problems' started by kayl, Nov 18, 2015.

  1. kayl

    kayl Member

    This morning we started seeing errors that appear to be running about every 50 min or so. We see this string:

    Undefined index: user_id 27 minutes ago - library/XenForo/Visitor.php:670
    Undefined index: user_id 27 minutes ago - library/XenForo/Visitor.php:670
    Undefined index: user_id 27 minutes ago - library/XenForo/Visitor.php:670
    Undefined index: user_id 27 minutes ago - library/XenForo/Model/User.php:2428
    Undefined index: user_id 27 minutes ago - library/XenForo/Visitor.php:368
    Undefined index: user_id 27 minutes ago - library/XenForo/Visitor.php:358
    Undefined index: user_id 27 minutes ago - library/XenForo/Visitor.php:347
    Undefined index: user_id 27 minutes ago - library/XenForo/Visitor.php:334
    Undefined index: user_id 27 minutes ago - library/XenForo/Visitor.php:670
    Undefined index: is_admin 27 minutes ago - library/XenForo/Visitor.php:670
    Undefined index: csrf_token_page 27 minutes ago - library/XenForo/Visitor.php:670
    Undefined index: is_admin 27 minutes ago - library/XenForo/Visitor.php:670
    Undefined index: is_moderator 27 minutes ago - library/XenForo/Visitor.php:670
    Undefined index: user_id 27 minutes ago - library/XenForo/Visitor.php:670
    Undefined index: user_id 27 minutes ago - library/XenForo/Visitor.php:670
    Undefined index: user_id 27 minutes ago - library/XenForo/Visitor.php:670
    Undefined index: user_id 27 minutes ago - library/XenForo/Visitor.php:670
    Undefined index: timezone 27 minutes ago - library/XenForo/Visitor.php:464
    Undefined index: language_id 27 minutes ago - library/XenForo/Visitor.php:463
    Undefined index: permission_combination_id
    Undefined index: global_permission_cache 27 minutes ago - library/XenForo/Visitor.php:450
    Undefined index: is_admin 27 minutes ago - library/XenForo/Visitor.php:417

    The stack always refers back to "csrf-token-refresh"

    Code:
    Generated By: Unknown Account, 30 minutes ago
    
    Stack Trace
    
    #0 /home/tsdf/public_html/library/XenForo/Visitor.php(670): XenForo_Application::handlePhpError(8, 'Undefined index...', '/home/tsdf/publ...', 670, Array)
    #1 /home/tsdf/public_html/library/XenForo/ControllerPublic/Login.php(183): XenForo_Visitor->offsetGet('csrf_token_page')
    #2 /home/tsdf/public_html/library/XenForo/FrontController.php(347): XenForo_ControllerPublic_Login->actionCsrfTokenRefresh()
    #3 /home/tsdf/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #4 /home/tsdf/public_html/index.php(13): XenForo_FrontController->run()
    #5 {main}
    
    Request State
    
    array(3) {
      ["url"] => string(59) "http://www.sitename.com/login/csrf-token-refresh"
      ["_GET"] => array(0) {
      }
      ["_POST"] => array(4) {
      ["_xfRequestUri"] => string(1) "/"
      ["_xfNoRedirect"] => string(1) "1"
      ["_xfToken"] => string(8) "********"
      ["_xfResponseType"] => string(4) "json"
      }
    }
    
    We are running Xenforo 1.4.3. We've made no changes. No new add-ons or updates. It just suddenly started this morning.

    Not sure if this is relevant but, it started right after someone tried to register but was triggered in the Spam Trigger and we rejected their registration.

    Can anyone give me some guidance?
     
  2. kayl

    kayl Member

    Well, whatever it was it seems to have stopped. It lasted about 18 hours.
     
  3. Mike

    Mike XenForo Developer Staff Member

    Looks to me like there might have been some opcode cache corruption. Are you running PHP 5.4 with APC perchance?
     
  4. kayl

    kayl Member

    Thanks for reply Mike. No, we are running PHP 5.5.27 without APC.
     

Share This Page