1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Server Error Installation.

Discussion in 'Troubleshooting and Problems' started by Cobro, Dec 28, 2014.

  1. Cobro

    Cobro Member

    iconv_set_encoding(): Use of iconv.internal_encoding is deprecated

    1. XenForo_Application::handlePhpError()
    2. iconv_set_encoding() in Zend/Validate/Hostname.php at line 521
    3. Zend_Validate_Hostname->isValid() in Zend/Validate/EmailAddress.php at line 487
    4. Zend_Validate_EmailAddress->_validateHostnamePart() in Zend/Validate/EmailAddress.php at line 546
    5. Zend_Validate_EmailAddress->isValid() in XenForo/Helper/Email.php at line 64
    6. XenForo_Helper_Email::isEmailValid() in XenForo/DataWriter/User.php at line 673
    7. XenForo_DataWriter_User->_verifyEmail()
    8. call_user_func_array() in XenForo/DataWriter.php at line 982
    9. XenForo_DataWriter->_runVerificationCallback() in XenForo/DataWriter.php at line 725
    10. XenForo_DataWriter->_isFieldValueValid() in XenForo/DataWriter.php at line 643
    11. XenForo_DataWriter->set() in XenForo/DataWriter.php at line 995
    12. XenForo_DataWriter->bulkSet() in XenForo/Install/Model/Install.php at line 302
    13. XenForo_Install_Model_Install->insertAdministrator() in XenForo/Install/Controller/Install.php at line 265
    14. XenForo_Install_Controller_Install->actionStep3b() in XenForo/FrontController.php at line 347
    15. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    16. XenForo_FrontController->run() in /home/server/domains/domian.com/public_html/install/index.php at line 18
  2. Brogan

    Brogan XenForo Moderator Staff Member

    What version of PHP is running on the server?
  3. Cobro

    Cobro Member

  4. Mike

    Mike XenForo Developer Staff Member

    What version of XF? This was resolved in 1.3.4.
  5. Cobro

    Cobro Member

    Okey then i just need to update and then everything should be good..

    Thank you very much for these information.
  6. oxojeck

    oxojeck New Member

    Hi guys, I have the same errors during install. My board version is 1.3.3, but I don't have upper cause I don't have money :(
    Are this serious errors? Can I install xenforo with them? Will it work properly? Thanks in advance!
  7. Tracy Perry

    Tracy Perry Well-Known Member

    Maybe regressing your PHP version to a 5.5.x series if running 5.6 or higher?
    oxojeck likes this.
  8. oxojeck

    oxojeck New Member

    Thanks, It helped.

Share This Page