• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Serious bug! Opening forums scrolls the page to the bottom in Chrome

Stuart Wright

Well-known member
#1
Using the latest version of Chrome for Windows (38.0.2125.101 m), when I open categories, the page opens fine.
2 examples:
1) https://www.avforums.com/categories/video-game-forums.517/ (reduce the window height to create a vertical scroll bar)
and 2) https://www.avforums.com/categories/playstation-forums.518/
But if I navigate into a forum, the page opens scrolled to the bottom.
2 examples:
1) https://www.avforums.com/forums/which-tv-should-i-buy.367/
2) https://www.avforums.com/forums/movie-forum.37/
This happens when you open every forum.

Opening all other page types seems to be fine.
This happens when logged in or as a guest.

I'm desperate for help because this is a problem which makes our forums look rubbish for all users on the latest version of Chrome on Windows at least. (It doesn't happen on Chrome for iOS).

[Edit : this happens in the default Xenforo style also, so could this be Javascript rather than css?]

Can anyone please take a look at our forums and help?
Thanks
 
Last edited:

Brogan

XenForo moderator
Staff member
#2
Does it do it on your sandbox?

If so, try a default style to rule that out.

Then you may need to start disabling add-ons.
 

Stuart Wright

Well-known member
#3
Thanks Paul. Went straight for Defer JS and once disabled, the problem goes away.
So some Javascript being moved by Defer JS is causing the page to scroll to the bottom.
 

Mouth

Well-known member
#4
I'd be starting with looking at why you have the exelator hijack virus in your page source code!

Nevermind, obviously not the issue. Suggest you still look at your exelator issue though.
 

Stuart Wright

Well-known member
#5
I'd be starting with looking at why you have the exelator hijack virus is your page source code!
If you mean
Code:
<SCRIPT TYPE="text/javascript" SRC="https://loadeu.exelator.com/load/?p=445&c=1381178&g=051&j=d&ctg=&kw="></script>
that's not a hijack virus.
 

Xon

Well-known member
#8
Thanks Paul. Went straight for Defer JS and once disabled, the problem goes away.
So some Javascript being moved by Defer JS is causing the page to scroll to the bottom.
I've also had this recently happen with the latest chrome version. IE, Firefox and older versions of Chrome are unaffected.

Disabling the DeferJS addon and the problem goes away.