1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Seeing double near bottom of my forum.

Discussion in 'XenForo Questions and Support' started by andrewkm, Mar 29, 2015.

  1. andrewkm

    andrewkm Active Member

    Ok, so after hours of trying to figure this out, I am waving the white flag, I give up. I surrender. Please god help me lol!

    I am seeing double at the bottom of my forums in various areas.
    One "double" has to do with XenPorta2 PRO and one "double" has to do with another addon. This leads me to believe the problem is somewhere in my theme/template and not addon specific.

    Examples:

    "Go to first unread"
    [​IMG]

    and

    "Show ignored content"
    [​IMG]

    For a live example you can login with this forum account (so you dont have to waste time registering):
    Username: xenforohelp
    Password: 123123

    Go to this link:
    http://www.ecocitycraft.com/forum/t...tock-trader-events-betting-ipads-more.120447/

    Very bottom of page you will see the double "Go to First Unread" links.

    Please if you can figure out where to fix this I would be so grateful.
    My firebug shows this:

    [​IMG]

    Two of the same.... Still though I can't figure out why, how, and oh man. =P

    Many thanks in advance.
     
    Last edited: Mar 30, 2015
  2. Brogan

    Brogan XenForo Moderator Staff Member

    You will need to confirm whether it is style or add-on related, or both.

    Test in a default style.
    Disable add-ons and re enable them one at a time.
     
    andrewkm likes this.
  3. andrewkm

    andrewkm Active Member

    Testing now.

    Default style = Issue still there = http://i.imgur.com/FkaNFKz.png

    Disabling plugins.

    Disabled Ignore addon = issue still there.
    Disabled XenPorta2 = issue gone.

    Disabled XenPorta2 and Enabled Ignore addon = Issue still gone

    My issue is XenPorta2. So.... What now xP @Brogan (Perhaps tag @Jaxel here too)
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    You will need to post on the add-on thread for support with it.
     
  5. andrewkm

    andrewkm Active Member

    Alright, I've just done that. There's nothing you can think of off by hand? Anywhere to look to perhaps fix this. :(
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    I don't use the add-on and have no access to the code so have no idea what could be causing it.
     
  7. Jaxel

    Jaxel Well-Known Member

    I dont see any issue on the page you linked.
     
  8. andrewkm

    andrewkm Active Member

    Please login:

    Username: xenforohelp
    Password: 123123

    Go to:
    http://www.ecocitycraft.com/forum/threads/new-forum-organization-feature.120983/

    Bottom of the page double "Go to First Unread" buttons:

    [​IMG]

    As well try to hide forums and then go to the bottom of forum view:

    [​IMG]

    The double show ignore content is from another addon, however the issue is fixed by disabling XenPorta2
     
    Last edited: Mar 30, 2015
  9. andrewkm

    andrewkm Active Member

  10. Jaxel

    Jaxel Well-Known Member

    This is actually by design... If you look at ANY thread, the "Go to First Unread" links are wrapped around the contents of the thread. Both on the top and bottom...

    XenPorta however takes the first post of the thread and removes it from the contents and places it above the replies. Post a single reply, and you will see.
     
  11. andrewkm

    andrewkm Active Member

    Yes but this ruins other addons causing the following:

    [​IMG]

    Anyway I can fix the "Show Ignored Content" showing double here http://www.ecocitycraft.com/forum/ when you ignore a forum for example.

    Disabling xenporta fixes:

    [​IMG]
     
  12. andrewkm

    andrewkm Active Member

  13. Jaxel

    Jaxel Well-Known Member

    No it doesn't... all it does is remove the first post from the posts list and displays above as an article. I don't see that "Show Ignored Content" link. If its both above and below the posts lists, then its going to appear twice... above all the comments, and below all the comments.
     
  14. andrewkm

    andrewkm Active Member

    You can ignore forum for example here
    http://www.ecocitycraft.com/forum/forums/general-discussion.6/

    [​IMG]

    Select all options

    [​IMG]

    Then go back to

    http://www.ecocitycraft.com/forum/

    And scroll to the very bottom.

    [​IMG]
     
  15. Jaxel

    Jaxel Well-Known Member

    1.jpeg
     
    andrewkm likes this.
  16. andrewkm

    andrewkm Active Member

    Yes I understand the need for two buttons there now :)

    However my forum view is messed up with the Show Ignored Content related to the Ignore addon by waidingo. That link only shows once if I disable XenPorta2 yet twice with XenPorta2 enabled. Thus making XenPorta2 conflict with this addon.

    Explained in above reply how to get the "Show Ignored Content" link to show.
     
  17. Jaxel

    Jaxel Well-Known Member

    I dont think this issue really has anything to do with XenPorta2, and more about the other addon.
     
    andrewkm likes this.
  18. andrewkm

    andrewkm Active Member

    Alright I've tagged @Jon W to see why this confliction is taking place. (He is the author of the other addon)
    Thanks for looking into this @Jaxel.
     

Share This Page