• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 search for numbers does not work

snoopy5

Well-known member
#1
Hi

when I type in my search box i.e. 28-75, the search does not bring any results, although there are a ot of postings with "28-75" in it.

Also the search for "28" does not bring any results. In ACP the minimum search length is 2

What could be the reason for it?
 

shawn

Well-known member
#2
Are you using the default mysql fulltext search, or the Xenforo Enhanced Search product?

My bet is that your mysql minimum index length is set to 3, and mysql doesn't understand 28-75. Does "25-75" (in quotes) return a result?
 

snoopy5

Well-known member
#3
Are you using the default mysql fulltext search, or the Xenforo Enhanced Search product?

My bet is that your mysql minimum index length is set to 3, and mysql doesn't understand 28-75. Does "25-75" (in quotes) return a result?
no, same results with and without quotes...


how can I check whether my mysql has a minimum of 2 or 3 characters?
 

snoopy5

Well-known member
#7
Hi

I called my webhoster. I am not allowed to change the limit in mysql. Its is set to 4 there. In the XF-ACP have set it to 2. But this obviously does not have any influence because of the mysql settings.

Where do I find & enable the enhanced search and what is the benefit and downside over the normal search?

The modification of digitalpoint you mentioned, is it that one?:

http://xenforo.com/community/resources/change-analyzer-for-enhanced-search.643/
 

shawn

Well-known member
#8
If you can't change the mysql settings, I doubt you can install Java and Elasticsearch to run XF Enhanced Search. You'd have to move to a VPS account first.