1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Browser Issue Safari new user

Discussion in 'Resolved Bug Reports' started by mungo, Mar 30, 2011.

  1. mungo

    mungo New Member

    browser: Safari 5.0.4 for windows (latest release)

    xenForo: 1

    problem: user cannot upload an avatar
     
  2. Kier

    Kier XenForo Developer Staff Member

    On this forum or elsewhere? Is there any more information about any errors received?
     
  3. mungo

    mungo New Member

    i've just tried it on this forum and i couldn't upload an avatar here.

    there is no error message.

    user name > avatar (from the drop down)
    i click the 'choose file' button
    when the window opens for you to select a file opens, i can navigate to my folder.
    as soon as i select a file, the form on xenForo disappears and no file appears in the dialogue box in windows explorer!

    hope this makes sense, if not i'll elaborate.

    (safari right out of the box, i just use it for testing)
     
  4. Kier

    Kier XenForo Developer Staff Member

    We have found how to reproduce this, and it looks like a really nasty Safari bug. We are looking for a workaround, but this may be something that Apple needs to fix.

    The problem is that clicks on the upload dialog register clicks on the page behind, so any clicks that do not overlap the XF overlay area register as a click to dismiss the overlay.
     
  5. mungo

    mungo New Member

    ... i'm not really bothered, i doubt many windows users have safari!!

    i just came across it as i was creating some seed/test members of my forum, so i figured i should let you know.
     
  6. Kier

    Kier XenForo Developer Staff Member

    We're looking to see if it's been fixed in a development version of Safari, but we haven't found any Apple bug reports relating to it.
     
  7. Kier

    Kier XenForo Developer Staff Member

Share This Page