• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Browser issue Safari autofill annoyance with xf2

Affected version
v2 beta 5

Mr Lucky

Well-known member
#1
With xenforo 2 on Safari I am finding my username is autofilled in fields I don't want, e.g. the User list filter box, in user edit username box (my name goes there)

In Safari prefs of course I can disable autofill for usernames and passwords, but then it also disable for fields I want, i.e. when logging so that is no use.

This isn't happening with xenforo 1 so i wonder if there is some setting in xf2 to make it behave like xf1 in this regard?
 
Last edited:

Chris D

XenForo developer
Staff member
#2
As it’s different in XF1 we’ll look at it from the angle of a bug report.

There may be things like autofill not being disabled on some fields or different field types being used in XF1 (we used a lot of “search” type inputs in XF1 whereas we don’t in XF2).
 

lantek

Active member
#3
With xenforo 2 on Safari I am finding my username is autofilled in fields I don't want, e.g. the User list filter box, in user edit username box (my name goes there)

In Safari prefs of course I can disable autofill for usernames and passwords, but then it also disable for fields I want, i.e. when logging so that is no use.

This isn't happening with xenforo 1 so i wonder if there is some setting in xf2 to make it behave like xf1 in this regard?
I'm seeing this on XF1 with the latest Safari.
 

Chris D

XenForo developer
Staff member
#4
Unfortunately there seems to be little we can do (or will do) to rectify this. It is ultimately the chosen behaviour for Safari and it's not something we should attempt to override (the workarounds involve dodgy stuff like hidden fields which is just not an adequate solution).

The problem is also not new in XF2. Here's it happening in an XF1 installation:

1508279713215.png

I originally thought it might be a regression or otherwise controllable but I don't use Safari and in Chrome I use a proper password manager that only fills when I ask it to! But unfortunately there's no reasonable workarounds to control its behaviour