1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RSS not working with nginx

Discussion in 'Troubleshooting and Problems' started by Alex Vojacek, Mar 13, 2013.

  1. Alex Vojacek

    Alex Vojacek Member

    Currently I have the whole forum fully functional, everything works, absolutely every link works perfectly with this simpley nginx rule

    location / {
    try_files $uri $uri/ /index.php?$uri&$args;
    }
    THIS and the friendly URLs active on xenforo. But as soon as I try to access the RSS it says "not found"
    http://foros.tecnogaming.com/forums/pc-gaming.10/index.rss
    If I disable friendly URL's on xenforo the RSS works perfectly so this is a nginx rules thing.
    Does anyone knows the rule to actually have functional RSS without having to disable the friendly urls inside xenforo?
     
  2. Alex Vojacek

    Alex Vojacek Member

    I fixed it :)

    For the record if anyone has this problem, be sure NOT to allow .rss extension on the nginx caching rule

    location ~* \.(ogg|ogv|svg|svgz|eot|otf|woff|mp4|ttf|css|atom|js|jpg|jpeg$
    expires max; log_not_found off; access_log off;
    }
     
    ideenwerk likes this.
  3. Brit Mansell

    Brit Mansell Member

    This was my issue as well. The rss rule was located in location.conf.
     
  4. Alex Vojacek

    Alex Vojacek Member

    Just for the record, the full nginx config for working rss is this:

    location / {
    try_files $uri $uri/ /index.php?$uri&$args;
    }


    location ~* \.(ogg|ogv|svg|svgz|eot|otf|woff|mp4|ttf|css|js|jpg|jpeg|gif|png|ico|zip|tgz|gz|rar|bz2|doc|xls|exe|ppt|tar|mid|midi|wav|bmp|rtf)$ {
    expires 30d; log_not_found off; access_log off;
    add_header "Access-Control-Allow-Origin" "*";
    add_header Cache-Control "public";
    }
     

Share This Page