1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

As Designed RSS Feeder Bug

Discussion in 'Resolved Bug Reports' started by semprot, May 4, 2014.

  1. semprot

    semprot Active Member

    How to reproduce on XF 1.3.1 :
    1. Create a new feed. As a sample, it's better to use the feed that changes less frequent.
    2. Force all items in feed to be posted by clicking "Import Now" several times.
    3. After all are posted, delete the posted threads.
    4. Force all items in feed to be posted by clicking "Import Now" several times. (you can rebuild cache after this). However no thread will be created at all.
    5. Delete the feed data.
    6. Create a new feed.
    7. Now clicking "Import Now" will post threads correctly again.
     
  2. Chris D

    Chris D XenForo Developer Staff Member

    This is working as expected, then.

    A log is maintained for each feed so that duplicate content isn't posted. The only way to remove the log items is via the database or, as you have already ascertained, by deleting the feed and recreating it.

    I've used the feeds feature several times before, and also deleted the specific items I did not want. As a consequence, what you're calling a bug, is exactly what I would want to happen. I wouldn't want those items to be recreated if I'd already deleted them.
     
  3. semprot

    semprot Active Member

    Okay, that makes sense.

    Moderator can close this thread :)
     

Share This Page