Duplicate Rich-Editor has problem on mobile devices with SwiftKey/Chrome

Affected version
1.5

au lait

Well-known member
As has already been written here (https://xenforo.com/community/threads/rich-text-editor-problems-with-chrome-on-android.100315/)
, I can confirm. Unfortunately the autocorrection is only sporadically problematic. I can't find out what this depends on. But I found out that there is a permanent problem with the punctuation marks.

This problem is browser independent (mainly Chrome) as well as SwiftKey and XenForo Richt Editor. In our forum (android forum) this problem is massive. Since many use this combination.


https://www.android-hilfe.de/forum/anregungen-zum.2/editorproblem-xenforo-chrome-64-swiftkey.864118-page-10.html (german)

I would be happy if this problem is fixed before XF1.5 is dead.
 

Attachments

Chris D

XenForo developer
Staff member
Indeed, I do believe it is the same bug.

Primarily the issue is with editors that render within an iframe. Browsers, keyboards etc. seem to be having a hard time in maintaining compatibility with that. But with that in mind XF2 shouldn't have such issues so, given the status of XF 1.5 at this point, we should be aiming for moving away from XF 1.5 more than spending time working around obscure third party issues.
 

au lait

Well-known member
But with that in mind XF2 shouldn't have such issues so, given the status of XF 1.5 at this point, we should be aiming for moving away from XF 1.5 more than spending time working around obscure third party issues.
you're right partially...

But considering the widespread use of XF1 and the fact that many won't switch immediately, for lack of add-ons or even for lack of desire.
With the increasing use of mobile devices, I find this statement wrong!
 
Top