1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 rewrite adding root path to url

Discussion in 'Troubleshooting and Problems' started by audiokid, Dec 9, 2015.

  1. audiokid

    audiokid Active Member

    Last edited: Dec 9, 2015
  2. Mike

    Mike XenForo Developer Staff Member

    If it's just a few, it sounds like there are customizations in your .htaccess. Can you show the contents of that?
     
  3. audiokid

    audiokid Active Member

    Thanks Mike.

    Code:
    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #    SecFilterEngine Off
    #    SecFilterScanPOST Off
    #</IfModule>
    
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 405 default
    ErrorDocument 406 default
    ErrorDocument 500 default
    ErrorDocument 501 default
    ErrorDocument 503 default
    
    <IfModule mod_rewrite.c>
        RewriteEngine On
    
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        #RewriteBase /xenforo
    
        #    This line may be needed to enable WebDAV editing with PHP as a CGI.
        #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
     
  4. audiokid

    audiokid Active Member

    @Mike
    Oddly, if I deselect Include Content Title in URLs, it fixes. This just started in 1.5.3.
     
  5. audiokid

    audiokid Active Member

    Update:
    It may be something in cpanel. standby , I will confirm
     
  6. audiokid

    audiokid Active Member

    I have no idea how this happened but it was directly related to Firefox 42.0 cache and something xenForo contributed to.
    Is there a way to put something in a header so this can't happen? Clearing browser cache resolved it.
     
  7. Mike

    Mike XenForo Developer Staff Member

    There really isn't any reason that this should happen with the default system (it's not something we've had other reports of), so I couldn't recommend how to prevent it.
     

Share This Page