XF 2.2 Restarting rebuild jobs awaiting completion from CLI ?

Mouth

Well-known member
If a CLI rebuild job ( php cmd.php [etc.] ) stops without finishing, ACP provides a message of "There are manual rebuild jobs awaiting completion. Continue running them.".

Is the only way to continue a CLI rebuild by using the browser? Eg. You cannot continue using CLI? If I use the same CLI command, it restarts the rebuild rather than continuing.
 
Solution
My apologies, what is happening is probably expected.

You'll want to set the --max-execution-time option to 0 to avoid it stopping before it's finished:

Code:
php cmd.php xf:run-jobs --manual-only --max-execution-time 0

You won't get any feedback but once you see:

Code:
All outstanding jobs have run.

All jobs should have completed.

Mouth

Well-known member
I think you’ll want the xf:run-jobs command with the --manual-only option.
This doesn't appear to work?
php cmd.php xf:run-jobs --manual-only appears to be active for ~30sec (until "All outstanding jobs have run." and command prompt returns) and shortly after "There are manual rebuild jobs awaiting completion. Continue running them." appears in ACP again.

xf_job.last_run_date on the task gets updated.
 
Last edited:

Chris D

XenForo developer
Staff member
You may be right. I think it comes up with:

Code:
All outstanding jobs have run.

When there is more than one manual job to be run and before they are all finished.

I'll take a look at this, it appears to be a bug. You may have to run it via the browser for now but I'll reply if I have a workaround that allows the CLI to be used.
 

Chris D

XenForo developer
Staff member
My apologies, what is happening is probably expected.

You'll want to set the --max-execution-time option to 0 to avoid it stopping before it's finished:

Code:
php cmd.php xf:run-jobs --manual-only --max-execution-time 0

You won't get any feedback but once you see:

Code:
All outstanding jobs have run.

All jobs should have completed.
 
Solution
Top