1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 RESOLVED: XenForo not using SSL

Discussion in 'Troubleshooting and Problems' started by Enstage, Sep 25, 2016.

  1. Enstage

    Enstage Member

    Hello,

    I've just moved my installation over to a new server and put it through Cloudflare. I am trying to use Cloudflare's free SSL certificate.

    I'm experiencing an issue where ONLY the main page of my XenForo installation is not working with SSL.

    If I go to https://example.com/ it automatically changes that to http://example.com. However, if I go to https://example.com/anything/at/all/ it will remain as HTTPS.

    I am using the default XenForo htaccess unmodified, I also had my own certificate before this, which worked on the new server. No errors are logged anyway (client console, XenForo, Apache). All users are experiencing this issue. I've tried disabling all plugins, no effect.

    Thanks.
     
  2. Enstage

    Enstage Member

    I've traced the issue back to an issue with Cloudflare, I'm using some temporary page rules over there until I figure out exactly what the problem is.
     
  3. Mouth

    Mouth Well-Known Member

    URL @ /admin.php?options/list/basicBoard ?
     
    Enstage likes this.
  4. Enstage

    Enstage Member

Share This Page