1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 required user field gets ignored

Discussion in 'Troubleshooting and Problems' started by kleezy, Feb 9, 2014.

  1. kleezy

    kleezy Member

    I see new user registering without completing one of my required user fields.

    Users > Custom User fields > Name

    Regular expression:
    Code:
    ^[A-Za-z\s]{1,}[\.]{0,1}[A-Za-z\s]{0,}$
    Field is required is checked.

    What am I missing?
     
    Last edited: Feb 10, 2014
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Have you also checked?
    upload_2014-2-9_18-43-37.png
     
  3. kleezy

    kleezy Member

    Yes on "User editable"
    not "edit once".
     
  4. kleezy

    kleezy Member

    After opening a trouble ticket and working closely with XenForo support we determined that the Tapatalk plugin allows new signups from Tapatalk without filling in required fields.

    Contacting Tapatalk to add the option to disable New signup and to also be following forum rules. The VB version of the plugin allows to disable new registration via tapatalk while the XF version does not have that option (yet).
     
  5. fEaRz

    fEaRz Member

    Open the file mobiquo/config/config.txt

    Code:
    inappreg = 0
    inappsignin = 0
    Open the file mobiquo/include/get_config.php

    change

    Code:
    $config_list['inappreg'] =  new xmlrpcval(isset($register_setup['enabled']) && $register_setup['enabled'] ? '1' : '0', 'string');
    to

    Code:
    $config_list['inappreg'] =  new xmlrpcval(isset($register_setup['enabled']) && $register_setup['enabled'] ? '0' : '0', 'string');
     
    kleezy likes this.
  6. kleezy

    kleezy Member

    Perfect. That did the trick.

    Thank you.
     
  7. kleezy

    kleezy Member

Share This Page