1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Reply box / Advanced Editor disappeared

Discussion in 'Troubleshooting and Problems' started by mobilephone2003, Nov 28, 2013.

  1. Hi folks

    I have some members saying they can't see the advanced editor. I've disabled a bunch of addons to no effect, and I'm not sure what could be causing this.

    [​IMG]

    Have I derped up somewhere? I'm stumped

    Thanks in advance
     
  2. Adam Howard

    Adam Howard Well-Known Member

    Please provide us a link to your site, so that someone here, such as myself may look into this.

    In the mean time, to make sure it is not an add-on add this into your config.php file

    PHP:
    $config['enableListeners'] = false;
     
  3. Sure, thanks, I've done that now and asking a person who is online.

    I've added the site to my signature, but i can't reproduce this with my test account, but 2 seperate people have contacted me (1 with the screenshot above)

    Edit: Still apparently missing
     
  4. Adam Howard

    Adam Howard Well-Known Member

    Thanks for registering. Your registration must now be approved by an administrator. You will receive an email when a decision has been taken.

    I have joined as the user, Adam.
     
  5. Adam Howard

    Adam Howard Well-Known Member

    Firebug tells me the following

    NetworkError: 500 Internal Server Error

    You may want to review your logs.
     
  6. Gotcha, not sure why you were put into approval, I have it set to question captcha

    http://gyazo.com/85bb3f7ea0bc98677eab8650c0daa152.png
     
  7. Adam Howard

    Adam Howard Well-Known Member

  8. Adam Howard

    Adam Howard Well-Known Member

    Server internal errors are not caused when you disabled add-ons. An error 500 is sort of a generic error, which basically means something has gone wrong.

    You may need to revert any changes you made before this error and you may also want to get in touch with your hosting service provider, as it could be possible they have changed something on their end.
     
  9. Adam Howard

    Adam Howard Well-Known Member

  10. Hmm... permissions are looking good

    I made only minor template changes (which should now be reverted), and have already removed addons I installed

    Is there a way to "reinstall" the files in case something has gone awry there?
     
  11. Adam Howard

    Adam Howard Well-Known Member

    I would first suggest you correct that error 500. That is hosting issue. I should be able to directly access that js file, but can not. I do not think this is so much a xenforo issue as it is a hosting issue.

    To answer you question though


    You can always overwrite the files with the stock files
    And you can technically do a "refresh" of sorts by rebuilding the master cache

    /install/index.php?upgrade/

    But would strong recommend you backup first. And even stronger recommend you look into that 500 server error, which is the root of the problem.
     
  12. Before i fill out a ticket, I'm seeing the following in cPanel's Error log, which points to the same directory:

    Code:
    [Thu Nov 28 11:46:57.441656 2013] [core:alert] [pid 130060] [client <IP Address>] <homedir>/public_html/forums/js/xenforo/.htaccess: Unknown filter provider DEFLATE, referer: <Many URLS from the Forums>
    Could the issue be coming from this (looks to be pointing to the same DIR) and has it been seen before?
     
  13. MattW

    MattW Well-Known Member

    Have you tried enabling gzip compression on the server? That is the DEFLATE module being referenced. What is the content of the .htaccess file in that folder? I don't think there should even be a .htaccess file in there.

    I've seen the editor vanish when the JS scripts aren't being loaded correctly.
     
    Adam Howard likes this.
  14. Liam W

    Liam W Well-Known Member

    That's the error causing the error 500 to be displayed.

    If you look in the htaccess file, you should see some lines with the word DEFLATE in them. As your apache install doesn't have deflate compiled in, then you should remove those lines.

    I would, however, highly recommend you contact your host and get them to install mod_deflate.

    EDIT: @mobilephone2003 you should just delete the js/xenforo/.htaccess file, it shouldn't be there.

    Liam
     
  15. .htaccess contains:

    Code:
    AddOutputFilterByType DEFLATE application/x-javascript
    Very odd, not sure how that got in there!
     
  16. Liam W

    Liam W Well-Known Member

    Just remove the entire file :)

    Also, disable debug mode on your live forum! Very bad idea to have it enabled...

    Liam
     
    MattW likes this.
  17. MattW

    MattW Well-Known Member

    As @Liam W said, just remove that .htaccess file and it should fix the problems you are having.
     
  18. Excellent, we're good to go, looks like it had derped up more than the editor too.

    Will poke the host to add mod_deflate.

    Thanks for your help guys! Hope this helps anybody else that might get this in the future!

    Edit: Just a note that I couldn't see this as admin, or on a test account, I'm guessing I either had the stuff cached or it didn't affect admin accounts... no idea, very odd.
     
    Adam Howard and MattW like this.
  19. MattW

    MattW Well-Known Member

    Glad it's all sorted now (y)
     

Share This Page