• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Registration dates are 1 day off....

#1
I noticed the people that joined my forum today all are being credited as having registered yesterday. I don't know how long this has been happening. I created a user and gave it a join date and saved the user, but the user is also credited as having registered 1 day earlier than the date I gave them. Any ideas what might be causing this?

I know it hasn't been going on for very long just not exactly sure how long.
 

LuvMeSumZen

Active member
#5
The join date isn't something that's configurable, so can you clarify what you're referring to here and what you mean by date the user is "credited" with?
Mike I just realized this may be related to the an add-on I have, but I will answer your question.

The 5 members I numbered have all registered today, but when their member cards are clicked it incorrectly credits them with having reg'd yesterday as seen in the card....

member regs.jpg
 

Mike

XenForo developer
Staff member
#6
That doesn't display the specific time of their registration -- you can see that in the control panel.
 

Mike

XenForo developer
Staff member
#8
I was mostly asking what it shows the registration date as in the control panel. If it shows that it was 11:59 PM, then that would technically be yesterday; if it shows as something like 12:01 AM then there may be some sort of unexpected offset. If it's showing that they registered at noon today, then something more extensive is likely going on.
 

LuvMeSumZen

Active member
#9
Yes all 5 of the members reg'd well past midnight central time (which is what the forum is set to) and the one I highlighted in the image reg'd just prior to 10:00 am. I'm getting ready to upgrade to .11 later - maybe that will reset something and fix it.
 

Mike

XenForo developer
Staff member
#10
I don't actually see a discrepancy when I look at your site, at least between the "specific" date being printed when you hover over the avatars in that newest members block. Do you see a difference between the hover and the member card date? Can you show what the ACP user edit page is showing as one of the user's registration dates as well (along with what the hover and member card say)?

It may be worth testing this with add-ons disabled and on the default style to take variables out of the equation.
 
#11
Yes, there's a discrepancy for certain, but I don't know how to do a better job of explaining it.

A user registered this morning at around 09:00 and popped up as the newest user after a refresh while I was on the site. His member card, profile page, and user account in the ACP all say he registered "Yesterday".

As another test, I just created a new user about 20 minutes ago. Likewise, his member card and profile page both say he he registered "Yesterday" but his ACP account info shows the correct "Joined" date as today's date. So it seems that when someone joins the normal route, the result is different from when I create a user.
 

Mike

XenForo developer
Staff member
#12
At this point, it might be easiest for you to submit a ticket with admin CP access so we can see this in place (and create a user temporarily, for example).