1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Redirection Script not working

Discussion in 'Installation, Upgrade, and Import Support' started by 51463, Oct 12, 2013.

  1. 51463

    51463 Well-Known Member

    I imported my forum from vbulletin 3.7 Everything went well. I didn't have any problems.

    But one thing i don't remember is weather or not it archived my log. I don't remember this step.

    How can i see if it logged. Where do i check and when i find it do i have to put that log file in my directory?

    I used this

    http://xenforo.com/community/resources/redirection-scripts-for-vbulletin-3-x.264/

    Even tho i don't know if i archived it. I tried anyways.


    I put those files in my directroy and edited the 1 file


    // $fileDir = '/var/www/vhosts/mywebsite.com/public_html/mywebsite';


    // define('IMPORT_LOG_TABLE', 'xf_import_log');



    What about this? Do i put this to true or false

    define('INCLUDE_PAGE_LINKS', false);
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    The import_log table name is usually one of these two. Try both:

    xf_import_log
    archived_import_log

    Or view your db tables using phpmyadmin to look for the table.

    You don't need to specify $fileDir if XF is in the same directory where vB was.

    INCLUDE_PAGE_LINKS refers to page links in thread URLs. Only enable this if XF is set to show the same number of posts per page as vB:

    Admin CP -> Home -> Options -> Messages
     
  3. 51463

    51463 Well-Known Member

    I looked into my phpmyadmin and i found both
    xf_import_log
    archived_import_log

    I'm not sure if i had it in the same directory. At first i didn't.

    My old forum was at www.mywebsite.com

    i added installed a fresh copy of Xenforo under www.mywebsite.com/test

    I imported and customized it and then after it was ready. I deleted vbulletin and moved all the xenforo files from test folder to www.mywebsite.com
     
  4. 51463

    51463 Well-Known Member

  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  6. 51463

    51463 Well-Known Member

    I figured out the problem.

    I had to remove these 2 little stupid slashes // at the start and left of $fileDir


    // $fileDir = '/var/www/vhosts/mywebsite.com/public_html/mywebsite';


    And for me it was archived_import_log not xf_import_log



    define('IMPORT_LOG_TABLE', 'archived_import_log');



    So for future reference mine worked with


     

Share This Page