1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Redirection Issues

Discussion in 'Troubleshooting and Problems' started by Tman222, Oct 26, 2015.

  1. Tman222

    Tman222 Member

    Hi all,

    I recently (within the last 4 months) upgraded my forum from vB 3.8.x to xenForo (http://forum.pcmech.com). Currently running the latest version - 1.5.2. I use Google Webmaster tools to regularly check for crawling errors and and I recently noticed that I got a bunch for my forum. For example, I end up getting errors for links in posts that follow the old forum structure, such as this thread:


    i.e. the two links in the post end up leading to errors:

    Google shows me several more of these errors, all of the same URL structure (i.e. ending in .html). Should these posts redirect to the actual thread on the forum? Are my redirection settings perhaps not configured properly and that is why I'm getting these errors?

    Thanks in advance for any help you can give me, I really appreciate it.
  2. Mike

    Mike XenForo Developer Staff Member

    Have you added redirects to cover that URL style? (They're from pre-import to XF. )You need rules in .htaccess to cover those. If you have added rules, what rules have you added?
  3. Tman222

    Tman222 Member

    Thanks Mike - I actually didn't add any specific rules for this URL style. However, I suppose it could be that the rules were added to the .htaccess file of the previous vB installation (and I forgot to bring them over with me). I'll check tonight and let you know.
  4. Tman222

    Tman222 Member

  5. Mike

    Mike XenForo Developer Staff Member

    Yeah, that would be the first step. I believe it also depends on the standard redirection scripts (for default links). You can grab them from the RM if you're not using them already.
  6. Tman222

    Tman222 Member

    Thanks Mike - following that link and implementing those rewrite rules did fix those type of html links I posted above. There are a few more though that are also .html that don't quite follow this format. What did you mean by RM? Thanks again.
  7. Tman222

    Tman222 Member

    Hi all - the above link took care of threads, but I'm still struggling with some other pages, e.g. member pages.

    I've got a bunch of links of the form:

    http://forum.pcmech.com/members/membername.html which I'd like to convert to Xenforo's standard, which is http://forum.pcmech.com/members/membername.id/

    I believe these .html links were also generated by vBSEO. Can anyone help me with a redirection/rewrite rule to convert them back into the original vB 3.8.x format?

    Thanks again for all your help.
  8. Mike

    Mike XenForo Developer Staff Member

    As those links don't have IDs in them, they can't be trivially redirected. There may be a script somewhere that can attempt to generate redirects for some, but it's much more complex than redirects with IDs.

Share This Page