1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Redirection Help

Discussion in 'Installation, Upgrade, and Import Support' started by mariohn, Mar 10, 2013.

  1. mariohn

    mariohn Member

    I just converted one of my forums from vBulletin 4.2 with vBSEO. Everything seems to ve working like it should except the redirection. The forums were at the root of the domain and they are still in the same place with xenforo. How can I redirect my old urls to the new ones for example:

    Nodes:
    vBulletin with vBSEO - domain.com/antes-y-despues-14/
    Xenforo with Route Changer - domain.com/foro/antes-y-despues.14/

    Here is what my .htaccess file looks like

    Code:
    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #    SecFilterEngine Off
    #    SecFilterScanPOST Off
    #</IfModule>
     
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
     
    RewriteEngine on
    RewriteRule [^/]+-[\d]+/.+-([\d]+)/index([\d]+).html showthread.php?t=$1&page=$2 [NC,L]
    RewriteRule [^/]+-[\d]+/.+-([\d]+)/ showthread.php?t=$1 [NC,L]
    RewriteRule [^/]+-([\d]+)/index([\d]+).html forumdisplay.php?f=$1&page=$2 [NC,L]
    RewriteRule [^/]+-([\d]+)/ forumdisplay.php?f=$1 [NC,L]
     
     
     
     
    <IfModule mod_rewrite.c>
        RewriteEngine On
     
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        #RewriteBase /xenforo
     
        #    This line may be needed to enable WebDAV editing with PHP as a CGI.
        #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
     
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
    Thanks
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Your .htaccess looks correct.

    1) Make sure the redirect scripts have been uploaded to your web root. The scripts can be downloaded here:

    http://xenforo.com/community/threads/redirection-scripts-for-vbulletin-3-x.5030/

    2) Edit the 301config.php file (one of the redirect scripts) and make sure the import_log table is correctly specified. By default it's commented out such that XenForo will automatically assume xf_import_log for the table name. But if your log table is different (such as "archived_import_log") then you need to specify it.
     
    mariohn likes this.
  3. mariohn

    mariohn Member

    Ok I uploaded the latest redirection script, now all the links redirect to the home page.
    Where can i find the name of my import_log table?
     
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That is typical of the log table not being correctly specified. You can confirm the name of the table by examining your database in phpmyadmin. Or just try the two default names which are:

    xf_import_log
    archived_import_log

    One of those will probably work.
     
    mariohn likes this.
  5. mariohn

    mariohn Member

    archived_import_log

    Worked!!
    Thank you so much!
     

Share This Page