• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 Redirect scripts for IPB doesn't work for me

#1
I converted from IPB to XF but for some reason no user, topics or posts are redirected to new link. If anyone can please help me it would be great!

Thank you!
 

Adam Howard

Well-known member
#2
I converted from IPB to XF but for some reason no user, topics or posts are redirected to new link. If anyone can please help me it would be great!

Thank you!
Thank you for posting it here. We've been have a lot of people asking for support in the pre-sales forum and I would suspect many them may not be valid customers of XenForo. So thank you for understanding. :)

I assume from your original post

Can someone please tell me where to upload ips2xf.php, 301config.php? My IPB forum was under /public_html/ and my xenforo is also under same directory.

None of my topics are being redirected. I was using 3.3.4 before conversion.

Thanks
source: http://xenforo.com/community/threads/convert-from-ipb-3-x.42023/#post-475452

That you are indeed using the IPB redirect script provided here
http://xenforo.com/community/threads/redirection-scripts-for-invision-power-board-3-1-x-3-2-x.27846/

The files in question go into your forums root.

In this case you said your forum was under /public_html/

So you will need to put those two files there.
 
#3
Got it all working :) Didn't added default db table in redirection script. Sometimes I am stupid... lol

Learning new things at XF ;) Btw do u know how do u change the drop down for subforums so that they are always shown? Same like IPB?

Thanks!
 

AWS

Well-known member
#4

Jake Bunce

XenForo moderator
Staff member
#6
How do u convert category to forum in Xenforo?
Unlike in some other forum applications, categories and forums are not interchangeable in XenForo. They are different data types. You need to create new nodes of the desired type to replace the old nodes.