1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Redirect on Rackspace Cloud

Discussion in 'Troubleshooting and Problems' started by zooki, Mar 17, 2013.

  1. zooki

    zooki Active Member

    My URLs do not redirect. - My previous forum was VB4. I managed to import all my threads and I made an archived import log! I uploaded the redirect files and put the table 'archived_import_log'

    When I test the redirect, i am taken back to the Forum home page.

    The URLs are all standard! nothing fancy. I installed Xenforo in /forum directory.

    I am using Rackspace Cloud. Any ideas what I need to do?

    Here is my .htaccess ( which is placed in the /forum folder)

    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    <IfModule mod_security.c>
        SecFilterEngine Off
        SecFilterScanPOST Off
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteBase /
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        #RewriteBase /xenforo
        #    This line may be needed to enable WebDAV editing with PHP as a CGI.
        #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
  2. zooki

    zooki Active Member

    The problem seems to have resolved itself. - Redirects are Working! It just needed a bit of time i guess!

Share This Page