• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Redirect Loop when De-activating Board

#1
Hello...!

I was hoping someone may be able to shed some light on this issue. I also experienced this with XenForo 1.4, but just lived with it.

Even if I clear out my all my redirects via cPanel, or clear out the .htaccess file... whenever I de-activate the board, I get a 302 temporary redirect loop. This only affects the homepage, ACP can still be accessed normally. It's quite unusual. I've tried changing the RewriteBase (and made sure to uncomment it) and the problem remains.

EDIT: I've also tried disabling all addons. Same results.

I can live with it, it just makes performing maintenance difficult as some things won't behave correctly when the homepage is trapped in a redirect loop.

Thanks in advance,
Kaz
 

Liam W

Well-known member
#2
What page is it actually being redirected to? XF should display a basic error page with a 503 response when the board is disabled.

Do you have something somewhere overriding 503 response codes?

Liam
 
#3
According to Fiddler, it's redirecting back onto itself. It performs the same no matter how I access the page, with or without www sub-domain.
I've not messed with any 503 responses to my knowledge.
 

Mike

XenForo developer
Staff member
#5
I found the URL via your customer area. I'm not sure the issue is actually coming from XF. There are some elements of the response that look like an XF reply, though there is one part that doesn't. I don't think we'd actually do anything that would trigger a 302 in this instance, so it might be a CloudFlare configuration.
 
#6
By 'homepage' do you mean the forum index or something else?
Yes, forum index.
I found the URL via your customer area. I'm not sure the issue is actually coming from XF. There are some elements of the response that look like an XF reply, though there is one part that doesn't. I don't think we'd actually do anything that would trigger a 302 in this instance, so it might be a CloudFlare configuration.
That URL may not have the issue, as I actually migrated hosts out of frustration and so far I haven't encountered it again. So it must have been a configuration issue with my previous host.

Thank you for your time, everyone. I'll post back if the issue comes up again.