1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Recovering from failed drive

Discussion in 'Troubleshooting and Problems' started by eccentricson, Jul 3, 2013.

  1. eccentricson

    eccentricson Member

    I have almost everything working, except I have a DB file that won't transfer. It's the .ibd file. Is there a way to rebuild this table?

    xf_email_template_compiled is the table.
     
  2. eccentricson

    eccentricson Member

    Along with the xf_permission table.
     
  3. Brogan

    Brogan XenForo Moderator Staff Member

    What do you mean by it "won't transfer"?
    Have you tried doing a database dump and restore?
    Are any of the tables marked as crashed? If so, have you tried repairing them?
     
  4. eccentricson

    eccentricson Member

    I'm getting IO errors so I can't copy, move, move, etc.

    Repair won't work either.
     
  5. Luke F

    Luke F Well-Known Member

    You're not trying to work from the failed drive directly are you? Take a partition image/clone and work from that
     
  6. eccentricson

    eccentricson Member

    Can't because dd fails because of Io errors.
     
  7. Biker

    Biker Well-Known Member

    Because nobody else has, I'm going to ask the obvious. Where are your backups?
     
  8. eccentricson

    eccentricson Member

    They exist.... But apparently the backup database button wasn't checked. The site files are all there but the actual database isn't...
     
  9. Brogan

    Brogan XenForo Moderator Staff Member

    Well without a recent backup of the database and a failed/corrupt hard drive, you don't really have a lot of options.
     
  10. eccentricson

    eccentricson Member

    I have all of the tables except permissions and email_template_compiled. There's no way to rebuild these tables?
     
  11. eccentricson

    eccentricson Member

    Everything is working, thanks to Mike from Xenforo. I dropped the table (still had the frm file), and was able to recreate the tables from the specs file (library/XenForo/Install/Data/MySql.php).
     
    AndyB likes this.

Share This Page