1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Rebuilding Search Index

Discussion in 'Enhanced Search Support' started by PetForums, Apr 24, 2015.

  1. PetForums

    PetForums Member

    I recently converted over from vbulletin to xenforo, my forum is hosted on a powerful dedicated server and has 361k threads and 5.3m posts. Everytime I try to restart building my search index cache my website becomes unresponsive.

    Any help would be greatful.

  2. Mike

    Mike XenForo Developer Staff Member

    Have you enabled Enhanced Search on your site? It doesn't look like it based on your search page (relevance is not a search option).
  3. PetForums

    PetForums Member

    Hi Mike, I'm new to xenforo so I am not exactly search. It does seem to be enabled, but under search options I havent got elastic search enabled but I dont know what I'm doing so I didnt want to break anything.
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Enable it like so:

    Then go to Tools -> Elasticsearch Setup and select the stemming analyzer, if desired.

    Then run the rebuild.
  5. PetForums

    PetForums Member

    Tried this, but get the error below when trying to rebuild search :

    An exception occurred: No response returned from Elasticsearch. Is it running? in /home/petforum/public_html/library/XenES/Search/SourceHandler/ElasticSearch.php on line 971

    1. XenES_Search_SourceHandler_ElasticSearch->_triggerFailedIndexError() in XenES/Search/SourceHandler/ElasticSearch.php at line 76
    2. XenES_Search_SourceHandler_ElasticSearch->finalizeRebuildSet() in XenForo/Search/Indexer.php at line 125
    3. XenForo_Search_Indexer->finalizeRebuildSet() in XenForo/Deferred/SearchIndex.php at line 74
    4. XenForo_Deferred_SearchIndex->execute() in XenForo/Model/Deferred.php at line 294
    5. XenForo_Model_Deferred->runDeferred() in XenForo/Model/Deferred.php at line 428
    6. XenForo_Model_Deferred->_runInternal() in XenForo/Model/Deferred.php at line 373
    7. XenForo_Model_Deferred->run() in XenForo/ViewRenderer/Abstract.php at line 352
    8. XenForo_ViewRenderer_Abstract::hasManualDeferredToRun() in XenForo/ViewRenderer/HtmlAdmin.php at line 130
    9. XenForo_ViewRenderer_HtmlAdmin->renderContainer() in XenForo/FrontController.php at line 618
    10. XenForo_FrontController->renderView() in XenForo/FrontController.php at line 158
    11. XenForo_FrontController->run() in /home/petforum/public_html/admin.php at line 13
  6. Brogan

    Brogan XenForo Moderator Staff Member

Share This Page