XF 2.2 "Rebuilding content group cache..." reloads infinitely

electrogypsy

Well-known member
I've had an issue for several months now where I constantly have a message in my admincp saying there are jobs that need to be ran. I click the link and it says

"Rebuilding... content group cache" and keeps reloading the page with that message.

I've let it run for upwards of 8+ hours and it's still going. If I close the tab the message in the admin cp appears again with the link and clicking it just goes through the same process.

I'm hoping someone has some advice for what I can try to resolve this issue? I'm not sure if it's related, but it seems like user promotions are not working and I'm not sure if it's related to this.
 

electrogypsy

Well-known member
You could try to run the cli variant if you have access to the shell.

Code:
php /path/to/xenforo/cmd.php xf:run-jobs

The mystery deepens:

PHP Fatal error: Cannot declare class XF\Cli\Command\Designer\Import, because the name is already in use in /home/nginx/domains/squattheplanet.com/public/src/XF/Cli/Command/AddOn/Import.php on line 11

Line 11 of Import.php:

class Import extends Command

I'm not sure what to do about that.
 

Jeremy P

XenForo developer
Staff member
There is no src/XF/Cli/Command/AddOn/Import.php file in the core. I'm not sure where it came from, but removing it should fix this.
 

electrogypsy

Well-known member
There is no src/XF/Cli/Command/AddOn/Import.php file in the core. I'm not sure where it came from, but removing it should fix this.

interesting. i removed the file and ran the cli for xf:run-jobs. it said "all outstanding jobs have run" which is good, but after a few minutes I still get the "There are manual rebuild jobs awaiting completion. Continue running them." message and "Rebuilding... content group cache" when I click on the link :(
 
Top