1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"Rebuild Caches" Not Working

Discussion in 'Troubleshooting and Problems' started by DeltaHF, Sep 18, 2011.

  1. DeltaHF

    DeltaHF Well-Known Member

    I imported a 5.9 million post database from vBulletin 3.8. The import went smoothly, but I've started to have some trouble rebuilding XenForo's caches.

    I first tried the rebuilding the caches immediately after the import, but that stopped with a nondescript error. I decided to skip the rest of the rebuild process at the time but have now returned to find the "Rebuild Cache" features do not appear to be working. Clicking on any of the "Rebuild Now" buttons takes me to the "Rebuilding..." page, which then immediately directs me back to the main Rebuild Cache page. This occurs with all of the cache rebuild options.

    I've checked the server's error logs but came up empty handed. Any ideas on what could be wrong?
     
  2. Floris

    Floris Guest

  3. DeltaHF

    DeltaHF Well-Known Member

    Thanks, but that doesn't really apply to my problem (I tried it anyway, though it made no difference). I can't rebuild any of the caches, not just the Search Index.
     
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Nothing in the log?

    Admin CP -> Tools -> Server Error Log

    It would be helpful to have a detailed error message.

    I can only guess. The rebuild options should take some amount of time to run. For example, I have 1000 users and rebuilding the user cache takes about 10 seconds. I can see it incrementing the batch numbers as it runs.
     
  5. DeltaHF

    DeltaHF Well-Known Member

    On a hunch I thought I'd give it another shot in another browser (Firefox) and it worked like a charm. :D

    I guess this should be moved into the "bug" section now, as it has something to do with the "rebuilding cache..." page Javascript. I had the issue in Google Chrome 14.0.835.163 on Mac OS. I also experienced this problem on a Windows 7 PC with Chrome, though I can't check its version right now.
     

Share This Page